gpo.zugaina.org

Search Portage & Overlays:

sys-libs/libselinux

SELinux userland library

Screenshots

  • libselinux-9999
    +pcre2 python ruby static-libs ruby_targets_ruby26 ruby_targets_ruby27 python_targets_python3_8 python_targets_python3_9 python_targets_python3_10 abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_s390_32 abi_s390_64

    View      Download      Browse     License: public-domain   
    Overlay: gentoo
  • libselinux-3.4_rc1
    ~amd64 ~arm ~arm64 ~mips ~riscv ~x86
    +pcre2 python ruby static-libs ruby_targets_ruby26 ruby_targets_ruby27 python_targets_python3_8 python_targets_python3_9 python_targets_python3_10 abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_s390_32 abi_s390_64

    View      Download      Browse     License: public-domain   
    Overlay: gentoo
  • libselinux-3.3
    amd64 arm arm64 ~mips ~riscv x86
    pcre2 python ruby static-libs ruby_targets_ruby25 ruby_targets_ruby26 ruby_targets_ruby27 python_targets_python3_8 python_targets_python3_9 python_targets_python3_10 abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_s390_32 abi_s390_64

    View      Download      Browse     License: public-domain   
    Overlay: gentoo
  • libselinux-2.3-r1001
    *
    python ruby static-libs abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_ppc_32 abi_ppc_64 abi_s390_32 abi_s390_64 python_abis_2.7 python_abis_3.4 python_abis_3.5 python_abis_3.6 python_abis_3.7 elibc_FreeBSD

    View      Download      Browse     License: GPL-2 public-domain   
    Overlay: progress
  • libselinux-2.2.2-r1002
    *
    python ruby static-libs abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_ppc_32 abi_ppc_64 abi_s390_32 abi_s390_64 python_abis_2.7 python_abis_3.4 python_abis_3.5 python_abis_3.6 python_abis_3.7 elibc_FreeBSD

    View      Download      Browse     License: GPL-2 public-domain   
    Overlay: progress

Runtime Dependencies

libselinux-9999









>=sys-libs/libsepol-9999:=[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]

!pcre2?
      ( >=dev-libs/libpcre-8.33-r1:=[static-libs?
,abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

pcre2?
      ( dev-libs/libpcre2:=[static-libs?
,abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

python?
      ( python_targets_python3_8?
            ( >=dev-lang/python-3.8.12_p1-r1:3.8 )
       python_targets_python3_9?
            ( >=dev-lang/python-3.9.9-r1:3.9 )
       python_targets_python3_10?
            ( >=dev-lang/python-3.10.0_p1-r1:3.10 )
       )

ruby?
      ( ruby_targets_ruby26?
            ( dev-lang/ruby:2.6 )
       ruby_targets_ruby27?
            ( dev-lang/ruby:2.7 )
       )

elibc_musl?
      ( sys-libs/fts-standalone )

libselinux-3.4_rc1









>=sys-libs/libsepol-3.4_rc1:=[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]

!pcre2?
      ( >=dev-libs/libpcre-8.33-r1:=[static-libs?
,abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

pcre2?
      ( dev-libs/libpcre2:=[static-libs?
,abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

python?
      ( python_targets_python3_8?
            ( >=dev-lang/python-3.8.12_p1-r1:3.8 )
       python_targets_python3_9?
            ( >=dev-lang/python-3.9.9-r1:3.9 )
       python_targets_python3_10?
            ( >=dev-lang/python-3.10.0_p1-r1:3.10 )
       )

ruby?
      ( ruby_targets_ruby26?
            ( dev-lang/ruby:2.6 )
       ruby_targets_ruby27?
            ( dev-lang/ruby:2.7 )
       )

elibc_musl?
      ( sys-libs/fts-standalone )

libselinux-3.3









>=sys-libs/libsepol-3.3:=[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]

!pcre2?
      ( >=dev-libs/libpcre-8.33-r1:=[static-libs?
,abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

pcre2?
      ( dev-libs/libpcre2:=[static-libs?
,abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

python?
      ( python_targets_python3_8?
            ( dev-lang/python:3.8 )
       python_targets_python3_9?
            ( dev-lang/python:3.9 )
       python_targets_python3_10?
            ( dev-lang/python:3.10 )
       >=dev-lang/python-exec-2:=[python_targets_python3_8
            (-)
      ?
,python_targets_python3_9
            (-)
      ?
,python_targets_python3_10
            (-)
      ?
] )

ruby?
      ( ruby_targets_ruby25?
            ( dev-lang/ruby:2.5 )
       ruby_targets_ruby26?
            ( dev-lang/ruby:2.6 )
       ruby_targets_ruby27?
            ( dev-lang/ruby:2.7 )
       )

elibc_musl?
      ( sys-libs/fts-standalone )

libselinux-2.3-r1001











>=sys-libs/libsepol-2.3[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_ppc_32
      (-)
?
,abi_ppc_64
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]










>=dev-libs/libpcre-8.33[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_ppc_32
      (-)
?
,abi_ppc_64
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
,static-libs?
]

ruby?
      ( ) python?
      (             ( python_abis_2.7?
                  ( dev-lang/python:2.7 )
             python_abis_3.4?
                  ( dev-lang/python:3.4 )
             python_abis_3.5?
                  ( dev-lang/python:3.5 )
             python_abis_3.6?
                  ( dev-lang/python:3.6 )
             python_abis_3.7?
                  ( dev-lang/python:3.7 )
             )
       )

libselinux-2.2.2-r1002











>=sys-libs/libsepol-2.2[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_ppc_32
      (-)
?
,abi_ppc_64
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]










>=dev-libs/libpcre-8.33[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_ppc_32
      (-)
?
,abi_ppc_64
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
,static-libs?
]

ruby?
      ( ) python?
      (             ( python_abis_2.7?
                  ( dev-lang/python:2.7 )
             python_abis_3.4?
                  ( dev-lang/python:3.4 )
             python_abis_3.5?
                  ( dev-lang/python:3.5 )
             python_abis_3.6?
                  ( dev-lang/python:3.6 )
             python_abis_3.7?
                  ( dev-lang/python:3.7 )
             )
       )