gpo.zugaina.org

Search Portage & Overlays:

sys-cluster/openmpi

A high-performance message passing library (MPI)

Screenshots

  • openmpi-4.1.4
    ~alpha amd64 arm arm64 ~ia64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux
    cma cuda cxx fortran ipv6 java libompitrace peruse romio openmpi_fabrics_ofed openmpi_fabrics_knem openmpi_rm_pbs openmpi_rm_slurm openmpi_ofed_features_control-hdr-padding openmpi_ofed_features_udcm openmpi_ofed_features_rdmacm openmpi_ofed_features_dynamic-sl java abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_s390_32 abi_s390_64

    View      Download      Browse     License: BSD   
    Overlay: gentoo

Runtime Dependencies

openmpi-4.1.4

!sys-cluster/mpich
!sys-cluster/mpich2
!sys-cluster/nullmpi








>=dev-libs/libevent-2.0.22:=[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
,threads]








dev-libs/libltdl:0[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]








>=sys-apps/hwloc-2.0.2:=[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]








>=sys-libs/zlib-1.2.8-r1[abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]

cuda?
      ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1:= )

openmpi_fabrics_ofed?
      ( sys-cluster/rdma-core )

openmpi_fabrics_knem?
      ( sys-cluster/knem )

openmpi_rm_pbs?
      ( sys-cluster/torque )

openmpi_rm_slurm?
      ( sys-cluster/slurm )

openmpi_ofed_features_rdmacm?
      ( sys-cluster/rdma-core )

java?
      ( >=virtual/jre-1.8:* )

fortran?
      ( virtual/fortran )

java?
      ( >=dev-java/java-config-2.2.0-r3 )