gpo.zugaina.org

Search Portage & Overlays:

net-misc/openvpn

Robust and highly flexible tunneling application compatible with many OSes

Screenshots

  • openvpn-2.3.6
    amd64 x86
    examples down-root iproute2 pam passwordsave pkcs11 +plugins +polarssl selinux +ssl systemd +lzo static userland_BSD

    View      Download      Browse     License: GPL-2   
    Overlay: argent-main (layman)
  • openvpn-2.3.2
    amd64 x86
    examples down-root iproute2 pam passwordsave pkcs11 +plugins polarssl selinux +ssl +lzo static userland_BSD

    View      Download      Browse     License: GPL-2   
    Overlay: argent-main (layman)
  • openvpn-2.2.1
    ~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-linux
    examples iproute2 ipv6 minimal pam passwordsave selinux ssl static pkcs11 userland_BSD

    View      Download      Browse     License: GPL-2   
    Overlay: crossdev (layman)

USE Flags

examples
Global: Install examples, usually source code
down-root
* This flag is undocumented *
iproute2
Global: Enabled iproute2 support instead of net-tools
Local: Enabled iproute2 support instead of net-tools
pam
Global: Adds support for PAM (Pluggable Authentication Modules) - DANGEROUS to arbitrarily flip
passwordsave
Global: Enables openvpn to save passwords
Local: Enables openvpn to save passwords
pkcs11
Global: Add support for PKCS#11 using dev-libs/pakchois
Local: Enable PKCS#11 smartcard support
+plugins
* This flag is undocumented *
+polarssl
* This flag is undocumented *
selinux
Global: !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
+ssl
* This flag is undocumented *
systemd
* This flag is undocumented *
+lzo
* This flag is undocumented *
static
Global: !!do not set this during bootstrap!! Causes binaries to be statically linked instead of dynamically
userland_BSD
* This flag is undocumented *
polarssl
Global: Use PolarSSL library instead of the default OpenSSL
ipv6
Global: Adds support for IP version 6
minimal
Global: Install a very minimal build (disables, for example, plugins, fonts, most drivers, non-critical features)
ssl
Global: Adds support for Secure Socket Layer connections