gpo.zugaina.org

Search Portage & Overlays:

net-analyzer/metasploit

Advanced framework for developing, testing, and using vulnerability exploit code

Screenshots

  • metasploit-9999
    development +java nexpose oracle +pcap test ruby_targets_ruby26

    View      Download      Browse     License: BSD   
    Overlay: pentoo (layman)
  • metasploit-6.0.10
    ~amd64
    development +java nexpose oracle +pcap test test ruby_targets_ruby26

    View      Download      Browse     License: BSD   
    Overlay: pentoo (layman)
  • metasploit-6.0.8
    ~amd64
    development +java nexpose oracle +pcap test test ruby_targets_ruby26

    View      Download      Browse     License: BSD   
    Overlay: pentoo (layman)
  • metasploit-3.4.1
    ~amd64 ~ppc ~sparc ~x86
    gtk sqlite postgres

    View      Download      Browse     License: BSD   
    Overlay: zugaina (layman)
  • metasploit-3.3.3
    ~amd64 ~ppc ~sparc ~x86
    gtk sqlite postgres

    View      Download      Browse     License: BSD   
    Overlay: zugaina (layman)

Runtime Dependencies

metasploit-9999

metasploit-6.0.10


ruby_targets_ruby26?
      ( virtual/ruby-ssl[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/actionpack-5.2.2:5.2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/activerecord-5.2.2:5.2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/activesupport-5.2.2:5.2[ruby_targets_ruby26
            (-)
      ] dev-ruby/bcrypt-ruby[ruby_targets_ruby26
            (-)
      ] dev-ruby/bcrypt_pbkdf[ruby_targets_ruby26
            (-)
      ] dev-ruby/bit-struct[ruby_targets_ruby26
            (-)
      ] dev-ruby/bson[ruby_targets_ruby26
            (-)
      ] dev-ruby/bundler:2[ruby_targets_ruby26
            (-)
      ] dev-ruby/concurrent-ruby[ruby_targets_ruby26
            (-)
      ] dev-ruby/dnsruby[ruby_targets_ruby26
            (-)
      ] dev-ruby/ed25519[ruby_targets_ruby26
            (-)
      ] dev-ruby/em-http-request[ruby_targets_ruby26
            (-)
      ] dev-ruby/eventmachine[ruby_targets_ruby26
            (-)
      ] dev-ruby/faker:2[ruby_targets_ruby26
            (-)
      ] dev-ruby/faraday[ruby_targets_ruby26
            (-)
      ] dev-ruby/faye-websocket[ruby_targets_ruby26
            (-)
      ] dev-ruby/filesize:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/hrr_rb_ssh[ruby_targets_ruby26
            (-)
      ] dev-ruby/irb[ruby_targets_ruby26
            (-)
      ] dev-ruby/jsobfu:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/json:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasm:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-concern[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-credential[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit_data_models[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-model[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-payloads:2.0.16[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit_payloads-mettle:1.0.2[ruby_targets_ruby26
            (-)
      ] dev-ruby/mqtt[ruby_targets_ruby26
            (-)
      ] dev-ruby/msgpack[ruby_targets_ruby26
            (-)
      ] dev-ruby/ruby-net-ldap[ruby_targets_ruby26
            (-)
      ] dev-ruby/net-ssh:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/network_interface[ruby_targets_ruby26
            (-)
      ] dev-ruby/nokogiri[ruby_targets_ruby26
            (-)
      ] dev-ruby/octokit[ruby_targets_ruby26
            (-)
      ] dev-ruby/openssl-ccm[ruby_targets_ruby26
            (-)
      ] dev-ruby/packetfu[ruby_targets_ruby26
            (-)
      ] dev-ruby/patch_finder[ruby_targets_ruby26
            (-)
      ] dev-ruby/pcaprub[ruby_targets_ruby26
            (-)
      ] dev-ruby/pdf-reader:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/pg:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/railties:5.2[ruby_targets_ruby26
            (-)
      ] dev-ruby/rb-readline[ruby_targets_ruby26
            (-)
      ] dev-ruby/recog:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/redcarpet[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-arch[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-bin_tools[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-core[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-encoder[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-exploitation[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-java[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-mime[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-nop[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-ole[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-powershell[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-random_identifier[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-registry[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-rop_builder[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-socket[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-sslscan[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-struct2[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-text[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-zip[ruby_targets_ruby26
            (-)
      ] dev-ruby/ruby-macho[ruby_targets_ruby26
            (-)
      ] dev-ruby/rubyntlm[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/ruby_smb-2.0.0[ruby_targets_ruby26
            (-)
      ] dev-ruby/rubyzip:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/sinatra[ruby_targets_ruby26
            (-)
      ] =dev-ruby/sqlite3-1.3*[ruby_targets_ruby26
            (-)
      ] dev-ruby/sshkey[ruby_targets_ruby26
            (-)
      ] www-servers/thin[ruby_targets_ruby26
            (-)
      ] dev-ruby/tzinfo:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/warden[ruby_targets_ruby26
            (-)
      ] dev-ruby/windows_error[ruby_targets_ruby26
            (-)
      ] dev-ruby/xdr[ruby_targets_ruby26
            (-)
      ] dev-ruby/xmlrpc[ruby_targets_ruby26
            (-)
      ] java?
            ( dev-ruby/rjb[ruby_targets_ruby26
                  (-)
            ] )
       nexpose?
            ( dev-ruby/nexpose[ruby_targets_ruby26
                  (-)
            ] )
       oracle?
            ( dev-ruby/ruby-oci8[ruby_targets_ruby26
                  (-)
            ] )
       pcap?
            ( dev-ruby/pcaprub:*[ruby_targets_ruby26
                  (-)
            ] dev-ruby/network_interface[ruby_targets_ruby26
                  (-)
            ] )
       development?
            ( dev-ruby/fivemat[ruby_targets_ruby26
                  (-)
            ] dev-ruby/pry[ruby_targets_ruby26
                  (-)
            ] dev-ruby/redcarpet[ruby_targets_ruby26
                  (-)
            ] dev-ruby/yard[ruby_targets_ruby26
                  (-)
            ] >=dev-ruby/rake-10.0.0[ruby_targets_ruby26
                  (-)
            ] >=dev-ruby/factory_girl-4.1.0[ruby_targets_ruby26
                  (-)
            ] )
       )

dev-db/postgresql:*[server]
||
      ( app-crypt/johntheripper-jumbo >=app-crypt/johntheripper-1.7.9-r1[-minimal
            (-)
      ] )

dev-libs/libxml2
dev-libs/libxslt
dev-libs/openssl
net-analyzer/nmap
net-libs/libpcap
sys-libs/zlib
>=app-eselect/eselect-metasploit-0.16

ruby_targets_ruby26?
      ( dev-lang/ruby:2.6 )

metasploit-6.0.8


ruby_targets_ruby26?
      ( virtual/ruby-ssl[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/actionpack-5.2.2:5.2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/activerecord-5.2.2:5.2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/activesupport-5.2.2:5.2[ruby_targets_ruby26
            (-)
      ] dev-ruby/bcrypt-ruby[ruby_targets_ruby26
            (-)
      ] dev-ruby/bcrypt_pbkdf[ruby_targets_ruby26
            (-)
      ] dev-ruby/bit-struct[ruby_targets_ruby26
            (-)
      ] dev-ruby/bson[ruby_targets_ruby26
            (-)
      ] dev-ruby/bundler:2[ruby_targets_ruby26
            (-)
      ] dev-ruby/concurrent-ruby[ruby_targets_ruby26
            (-)
      ] dev-ruby/dnsruby[ruby_targets_ruby26
            (-)
      ] dev-ruby/ed25519[ruby_targets_ruby26
            (-)
      ] dev-ruby/em-http-request[ruby_targets_ruby26
            (-)
      ] dev-ruby/eventmachine[ruby_targets_ruby26
            (-)
      ] dev-ruby/faker:2[ruby_targets_ruby26
            (-)
      ] dev-ruby/faraday[ruby_targets_ruby26
            (-)
      ] dev-ruby/faye-websocket[ruby_targets_ruby26
            (-)
      ] dev-ruby/filesize:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/hrr_rb_ssh[ruby_targets_ruby26
            (-)
      ] dev-ruby/irb[ruby_targets_ruby26
            (-)
      ] dev-ruby/jsobfu:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/json:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasm:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-concern[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-credential[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit_data_models[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-model[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit-payloads:2.0.12[ruby_targets_ruby26
            (-)
      ] dev-ruby/metasploit_payloads-mettle:1.0.2[ruby_targets_ruby26
            (-)
      ] dev-ruby/mqtt[ruby_targets_ruby26
            (-)
      ] dev-ruby/msgpack[ruby_targets_ruby26
            (-)
      ] dev-ruby/ruby-net-ldap[ruby_targets_ruby26
            (-)
      ] dev-ruby/net-ssh:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/network_interface[ruby_targets_ruby26
            (-)
      ] dev-ruby/nokogiri[ruby_targets_ruby26
            (-)
      ] dev-ruby/octokit[ruby_targets_ruby26
            (-)
      ] dev-ruby/openssl-ccm[ruby_targets_ruby26
            (-)
      ] dev-ruby/packetfu[ruby_targets_ruby26
            (-)
      ] dev-ruby/patch_finder[ruby_targets_ruby26
            (-)
      ] dev-ruby/pcaprub[ruby_targets_ruby26
            (-)
      ] dev-ruby/pdf-reader:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/pg:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/railties:5.2[ruby_targets_ruby26
            (-)
      ] dev-ruby/rb-readline[ruby_targets_ruby26
            (-)
      ] dev-ruby/recog:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/redcarpet[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-arch[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-bin_tools[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-core[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-encoder[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-exploitation[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-java[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-mime[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-nop[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-ole[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-powershell[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-random_identifier[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-registry[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-rop_builder[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-socket[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-sslscan[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-struct2[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-text[ruby_targets_ruby26
            (-)
      ] dev-ruby/rex-zip[ruby_targets_ruby26
            (-)
      ] dev-ruby/ruby-macho[ruby_targets_ruby26
            (-)
      ] dev-ruby/rubyntlm[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/ruby_smb-2.0.0[ruby_targets_ruby26
            (-)
      ] dev-ruby/rubyzip:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/sinatra[ruby_targets_ruby26
            (-)
      ] =dev-ruby/sqlite3-1.3*[ruby_targets_ruby26
            (-)
      ] dev-ruby/sshkey[ruby_targets_ruby26
            (-)
      ] www-servers/thin[ruby_targets_ruby26
            (-)
      ] dev-ruby/tzinfo:*[ruby_targets_ruby26
            (-)
      ] dev-ruby/warden[ruby_targets_ruby26
            (-)
      ] dev-ruby/windows_error[ruby_targets_ruby26
            (-)
      ] dev-ruby/xdr[ruby_targets_ruby26
            (-)
      ] dev-ruby/xmlrpc[ruby_targets_ruby26
            (-)
      ] java?
            ( dev-ruby/rjb[ruby_targets_ruby26
                  (-)
            ] )
       nexpose?
            ( dev-ruby/nexpose[ruby_targets_ruby26
                  (-)
            ] )
       oracle?
            ( dev-ruby/ruby-oci8[ruby_targets_ruby26
                  (-)
            ] )
       pcap?
            ( dev-ruby/pcaprub:*[ruby_targets_ruby26
                  (-)
            ] dev-ruby/network_interface[ruby_targets_ruby26
                  (-)
            ] )
       development?
            ( dev-ruby/fivemat[ruby_targets_ruby26
                  (-)
            ] dev-ruby/pry[ruby_targets_ruby26
                  (-)
            ] dev-ruby/redcarpet[ruby_targets_ruby26
                  (-)
            ] dev-ruby/yard[ruby_targets_ruby26
                  (-)
            ] >=dev-ruby/rake-10.0.0[ruby_targets_ruby26
                  (-)
            ] >=dev-ruby/factory_girl-4.1.0[ruby_targets_ruby26
                  (-)
            ] )
       )

dev-db/postgresql:*[server]
||
      ( app-crypt/johntheripper-jumbo >=app-crypt/johntheripper-1.7.9-r1[-minimal
            (-)
      ] )

dev-libs/libxml2
dev-libs/libxslt
dev-libs/openssl
net-analyzer/nmap
net-libs/libpcap
sys-libs/zlib
>=app-eselect/eselect-metasploit-0.16

ruby_targets_ruby26?
      ( dev-lang/ruby:2.6 )

metasploit-3.4.1

metasploit-3.3.3