gpo.zugaina.org

Search Portage & Overlays:

lxqt-base/liblxqt

Common base library for the LXQt desktop environment

Screenshots

  • liblxqt-9999
    +backlight

    View      Download      Browse     License: LGPL-2.1+ BSD   
    Overlay: qt (layman)
  • liblxqt-0.15.1
    ~amd64 ~arm ~arm64 ~ppc64 ~x86
    +backlight

    View      Download      Browse     License: LGPL-2.1+ BSD   
    Overlay: gentoo (distro)
  • liblxqt-0.15.0
    ~amd64 ~arm ~arm64 ~ppc64 ~x86
    +backlight

    View      Download      Browse     License: LGPL-2.1+ BSD   
    Overlay: gentoo (distro)
  • liblxqt-0.14.1
    amd64 ~arm ~arm64 ~ppc64 x86

    View      Download      Browse     License: LGPL-2.1+ BSD   
    Overlay: gentoo (distro)

ChangeLog

commit 716b4578b4b57d4caf861ff072475cdad3b0b114
Author: Andreas Sturmlechner <asturm@gentoo.org>
Date: Tue Dec 24 00:25:19 2019 +0100

*/*: Switch lxqt proj packages to cmake.eclass

Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

commit 088192653d4735a0fa555445c7945c77d24d1525
Author: Zamarin Arthur <arthurzam@gmail.com>
Date: Sat Jul 27 09:30:40 2019 +0300

lxqt-base/liblxqt: add IUSE="backlight" to live

use new option to disable polkit instead of patch

Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
Closes: https://github.com/gentoo/qt/pull/198
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit c93372104bbbd8aca35d4e0f90625a181d3ff15a
Author: Zamarin Arthur <arthurzam@gmail.com>
Date: Sun Jul 21 14:30:01 2019 +0300

lxqt-base/liblxqt: update polkit patch

Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
Closes: https://github.com/gentoo/qt/pull/196
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit 30fb127d9bea92e03789751cdc4a20766cdec5c1
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Wed Mar 13 01:01:09 2019 +0200

lxqt: remove 0.14.* and related ebuilds

These are available via the official Gentoo repository tree now.

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit 98237d481c59799e926bbf9301d003d81b2a9a29
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Wed Feb 27 13:55:42 2019 +0200

lxqt-base: version bump to 0.14.1

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit 13178a26c195afc0993f0cd4e229219ad7d5fbc3
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Wed Feb 27 13:49:24 2019 +0200

lxqt-base: bump 'dev-libs/libqtxdg' requirement to 3.3.1

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit 52686c46afd601da0e7b74b9d96a0e84b3b81dec
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Tue Feb 19 00:27:10 2019 +0200

lxqt-base: add 0.14.0 for testing

Bug: https://bugs.gentoo.org/676798
Package-Manager: Portage-2.3.61, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit a6d3c8fcfb555fd1c0293a037c4ba58c4fb7132b
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Mon Feb 18 23:55:22 2019 +0200

lxqt: add blockers for 'lxqt-base/lxqt-l10n'

Due to the translation changes, this package installs conflicting
files, not to mention it is deprecated upstream.

Package-Manager: Portage-2.3.61, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit 785faa19290ac8e77bca09e25a415fa9a38591c3
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Mon Feb 18 23:01:26 2019 +0200

lxqt: bump eapi to 7 for all related packages

Package-Manager: Portage-2.3.61, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit 10b50c2f61413462882e6009a3e1e2cb4c858bb3
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Mon Feb 18 21:28:57 2019 +0200

lxqt: remove all '-DPULL_TRANSLATIONS' options

Upstream has moved translations away from 'lxqt-base/lxqt-l10n' into
their own repositories, and moving to using 'Weblate'.

- https://github.com/lxqt/lxqt/issues/1495
- https://github.com/lxqt/lxqt/issues/1497

Package-Manager: Portage-2.3.61, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit 43d8e2c68af65d342b8e9ec9f416a8549bf912af
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Thu Jan 10 00:58:37 2019 +0200

lxqt-base: bump required versions on dependencies

Minimum versions for 'libqtxdg' and 'lxqt-build-tools' are now at
3.3.0 and 0.6.0.

Closes: https://bugs.gentoo.org/675022
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit d02583b11829e18ffbba099b2a6d805ce70a0e49
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Thu Jan 10 00:51:23 2019 +0200

lxqt-base/liblxqt: add 'ewarn' and make USE="policykit" the default

This is to stress the fact that upstream indeed doesn't support such
a build at this time.

Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>

commit a10da08a2dccd41eb5449acaa5dad3036eee6469
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Wed Dec 5 21:18:51 2018 +0200

lxqt-base/liblxqt: update polkit optional making patch

Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Package-Manager: Portage-2.3.52, Repoman-2.3.12

commit 182b079cd39004a600b9dddce6d47449574fd5fc
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Sun Sep 23 16:18:33 2018 +0300

lxqt: sync related ebuilds/metadata with the main Gentoo repo tree

With this, the metadata and 9999 ebuilds are in sync with the 0.13.0
versions found via the official Gentoo repository tree, with the
following exceptions:

- Polkit is optional.
- Some of the USE-flags are not used/included in the metadata.
- A patch for 'lxqt-config' is not needed.
- The handling of translations has been changed upstream, so
'lxqt-meta' does not depend on 'lxqt-l10n' due to file collisions.

Package-Manager: Portage-2.3.49, Repoman-2.3.11

commit 164da104c43c71833a52d740966ea27904fc9189
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Mon May 21 20:11:05 2018 +0300

lxqt-base/liblxqt: make polkit optional

Upstream changed the method of installing 'POLKIT_FILES', which
unconditionally creates a build-time dependency. We can avoid this
by adding a USE-flag for it, and patch the 'CMakeLists.txt' to handle it
as an option instead.

https://github.com/lxqt/liblxqt/commit/6570771dbf31f21f7cd5d6abc18d1bbb0f9b039a

Package-Manager: Portage-2.3.38, Repoman-2.3.9

commit c4d24b73b811d8f571b6a08b82b0e49fb0fa2142
Author: Jimi Huotari <chiitoo@gentoo.org>
Date: Fri Nov 3 19:21:01 2017 +0200

lxqt-base: add live ebuilds for the LXQt packages

Compared to Portage, 'lxqt-common' has been dropped, and
'lxqt-themes' has been added.

commit 017ec29f3f669a7c52da3e2f8c79549b5a26156a
Author: Michael Palimaka <kensington@gentoo.org>
Date: Sun Apr 24 03:33:47 2016 +1000

Remove unmaintained lxqt and related live ebuilds.

Gentoo-bug: 580308

commit 928938c47f504c9c9651bda003ce52fda908603e
Author: Davide Pesavento <pesa@gentoo.org>
Date: Sun Feb 21 22:29:16 2016 +0100

Update Copyright year in all ebuild headers.

commit b52f2c1d63ed04991b0a8aa80ccf1334b2ec3d65
Author: Michael Palimaka <kensington@gentoo.org>
Date: Mon Jan 25 23:11:57 2016 +1100

Migrate metadata for GLEP 67 and perform general cleanup.

commit 704e5dbd0674691292823e7eb2fd480dbe54686f
Author: Michael Palimaka <kensington@gentoo.org>
Date: Fri Oct 2 00:27:02 2015 +1000

lxqt-base/liblxqt: dev-qt/linguist-tools is a build-time dependency

Package-Manager: portage-2.2.20.1

commit 234975ce2f7eb5bd1a7b1c63478d18f641c15d66
Author: Davide Pesavento <pesa@gentoo.org>
Date: Mon Aug 24 23:07:24 2015 +0200

Revert https usage in metadata.xml and follow-up travis changes.

QA decided to revert similar changes in gentoo.git until bug 552720 is fixed.

This reverts the following commits:
b4007cace3e26a09f020a33a4b3102423cea9144
49557dda37e302180e5153cf6c9b9034b31a7788
17fd23a9513229e5160215d5d278746ad52fbc4b
6a9529abd08e159d1fbd6ca2fb8dfd69e51e2645

commit 6a9529abd08e159d1fbd6ca2fb8dfd69e51e2645
Author: Davide Pesavento <pesa@gentoo.org>
Date: Mon Aug 24 20:54:11 2015 +0200

Use https in metadata.xml

Signed-off-by: Davide Pesavento <pesa@gentoo.org>

commit 53c0294a5b0260c1d46cbb67df3e9fab07b2fd40
Author: Davide Pesavento <pesa@gentoo.org>
Date: Thu Aug 20 02:28:52 2015 +0200

Replace CVS "$Header:" with Git "$Id$".

commit 1bf6c0906e3895da74b1c1719149582775e3bddc
Author: Ben de Groot <yngwin@gentoo.org>
Date: Wed Feb 11 01:18:46 2015 +0800

lxqt-base: update some deps

commit 35c5479ad32aa29a6428bce6b000ca1f6b0daee9
Author: Ben de Groot <yngwin@gentoo.org>
Date: Tue Feb 10 18:44:06 2015 +0800

lxqt-base/liblxqt: update deps with kwindowsystem:5

commit 7c2284ff53156ab24a02f691c64ac8e7d1b67d75
Author: Michael Palimaka <kensington@gentoo.org>
Date: Mon Feb 2 03:57:21 2015 +1100

Welcome to 2015.

commit b8901f136eff718ae5974484e77e37f6d93fbfa1
Author: Michael Vetter <g.bluehut@gmail.com>
Date: Mon Jan 19 13:31:55 2015 +0100

[lxqt-base] LXQt SRC_URI change

On 18.01.2015 J. Leclanche announced on the LXDE mailing list that the
package download path will change in a few weeks (with the release of
0.9.0). The change of download paths affacts all version.

The new locations are already working, so here is the change that needs
to be done.

commit 4d2ee3c5d9a14c0d998921ce8b8d4f718e775035
Author: Jauhien Piatlicki <jauhien@gentoo.org>
Date: Sun Nov 16 12:51:09 2014 +0100

[LXQt] move LXQt-0.8.0 to the tree and fix bug #528616

commit 51d43db36c43e9c521cfbb589e07a1df522052ad
Author: Ben de Groot <yngwin@gentoo.org>
Date: Sat Nov 8 15:02:11 2014 +0800

razorqt-base/libqtxdg move to dev-libs

commit 190f15a0bfc1f1c85d033589bd87d41238a015f9
Author: Michael Vetter <g.bluehut@gmail.com>
Date: Wed Nov 5 13:53:30 2014 +0100

Remove switch for Qt5

Lxqt dropped Qt4 support, thus this is not needed anymore.
See commit b11ac14c5efa430e028f847cf3eefc8b8c5d150e and
2bf3372b424b4d371b944928f7a3800d0c22a692 in liblxqt repo for proof of
that.

Version 0.8 still has it, from then on they will change it.

commit 1b72c4e41cb8ac1e5d76ed7aaf8ba32b7927f561
Author: Jauhien Piatlicki <jauhien@gentoo.org>
Date: Mon Oct 27 23:14:07 2014 +0100

[lxqt-base/liblxqt] 0.8.0 release

commit a63e2cbd1df447f792c1dc355c2ef5c661e1ce47
Author: Jauhien Piatlicki <jauhien@gentoo.org>
Date: Mon Oct 20 23:08:02 2014 +0200

[lxqt-base/liblxqt] fix dependencies

commit 81db81943b6e79418864c23061323f7e63d46a4e
Author: Jauhien Piatlicki <jauhien@gentoo.org>
Date: Sun Oct 19 23:19:48 2014 +0200

[lxqt-base/liblxqt] update live ebuild, drop QT4 support

commit 2beaa3422450f38076cd259c2dec9083b28e7b2f
Author: Davide Pesavento <pesa@gentoo.org>
Date: Tue May 27 23:36:25 2014 +0200

[lxqt-base] Drop qt from metadata.

commit ce1feca908fbddf7279b67c21af5981230ac9e3c
Author: Jauhien Piatlicki <jauhien@gentoo.org>
Date: Tue May 27 21:04:53 2014 +0200

import LXQt 0.7.0 release to the tree, update live ebuilds

commit d38c5bf6dac37e543b922d8429b275a870c0771b
Author: Jauhien Piatlicki <jauhien@gentoo.org>
Date: Sat May 24 22:16:37 2014 +0200

[libqtxdg] Remove 0.5.3 (in tree); fix 9999 and move it back to razorqt-base category.

commit 1ddc5671b0e06aa4b373e21d3ab2b417f41b058e
Author: Michael Palimaka <kensington@gentoo.org>
Date: Mon May 12 19:06:13 2014 +1000

Remove thick manifests.

commit b77ad6dfef466c3af3ea1a9537a50992ce60e79a
Author: Harvey Mittens <teknocratdefunct@riseup.net>
Date: Mon May 12 03:02:59 2014 +0200

New ebuilds for LXQT.

* New category lxqt-base
* New repositories located at git.lxde.org (bug #501606)
* New release of LXDE-QT 0.7.0 (bug #509946)
* Updated dependencies for various packages
* lxinput-qt has been merged with lxqt-config
* Various new LXQT packages
* New ebuild for lximage-qt 0.2.0
* Updates to sddm ebuilds, with one for the released version