gpo.zugaina.org

Search Portage & Overlays:

dev-util/gnome-builder

An IDE for writing GNOME-based software

Screenshots

  • gnome-builder-42.1
    ~amd64 ~x86
    clang +devhelp doc flatpak +git +glade gtk-doc spell +sysprof test +webkit python_single_target_python3_8 python_single_target_python3_9 python_single_target_python3_10 test

    View      Download      Browse     License: GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0   
    Overlay: gentoo
  • gnome-builder-3.40.2
    amd64 x86
    clang +devhelp doc +git +glade gtk-doc spell sysprof test python_single_target_python3_8 python_single_target_python3_9 python_single_target_python3_10 test

    View      Download      Browse     License: GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0   
    Overlay: gentoo

Runtime Dependencies

gnome-builder-42.1

>=dev-libs/libdazzle-3.37.0[introspection]
>=dev-libs/glib-2.69.1:2
>=x11-libs/gtk+-3.24:3[introspection]
>=x11-libs/gtksourceview-4.0.0:4[introspection]
>=gui-libs/libhandy-1.5.0:1[introspection]
>=dev-libs/json-glib-1.2.0
>=dev-libs/jsonrpc-glib-3.41.0
>=x11-libs/pango-1.38.0



>=dev-libs/libpeas-1.22.0[python,python_single_target_python3_8
      (-)
?
,python_single_target_python3_9
      (-)
?
,python_single_target_python3_10
      (-)
?
]
dev-libs/libportal:=[gtk,introspection]
>=dev-libs/template-glib-3.28.0[introspection]
>=x11-libs/vte-0.65.0:2.91[introspection]
>=dev-libs/libxml2-2.9.0

webkit?
      ( >=net-libs/webkit-gtk-2.26:4=[introspection] )

sysprof?
      ( >=dev-util/sysprof-capture-3.37.1:4 >=dev-util/sysprof-3.37.1:0/4[gtk] )

>=app-text/cmark-0.29.0:0=

flatpak?
      ( dev-util/ostree >=net-libs/libsoup-2.52.0:2.4 >=sys-apps/flatpak-1.10.2 )

git?
      ( dev-libs/libgit2:=[ssh,threads] >=dev-libs/libgit2-glib-0.28.0.1[ssh] )

dev-libs/libpcre:3
dev-libs/libpcre2
>=dev-libs/gobject-introspection-1.54.0:=

python_single_target_python3_8?
      ( >=dev-python/pygobject-3.22.0:3[python_targets_python3_8
            (-)
      ] )

python_single_target_python3_9?
      ( >=dev-python/pygobject-3.22.0:3[python_targets_python3_9
            (-)
      ] )

python_single_target_python3_10?
      ( >=dev-python/pygobject-3.22.0:3[python_targets_python3_10
            (-)
      ] )

python_single_target_python3_8?
      ( >=dev-lang/python-3.8.12_p1-r1:3.8 )

python_single_target_python3_9?
      ( >=dev-lang/python-3.9.9-r1:3.9 )

python_single_target_python3_10?
      ( >=dev-lang/python-3.10.0_p1-r1:3.10 )

clang?
      ( sys-devel/clang:= )

devhelp?
      ( >=dev-util/devhelp-3.25.1:= )

glade?
      ( >=dev-util/glade-3.22.0:3.10= )

spell?
      ( >=app-text/gspell-1.8:0= app-text/enchant:2 )

gnome-builder-3.40.2

>=dev-libs/libdazzle-3.37.0[introspection]
>=dev-libs/glib-2.67.4:2
>=x11-libs/gtk+-3.22.26:3[introspection]
>=x11-libs/gtksourceview-4.0.0:4[introspection]
>=dev-libs/json-glib-1.2.0
>=dev-libs/jsonrpc-glib-3.19.91
>=x11-libs/pango-1.38.0



>=dev-libs/libpeas-1.22.0[python,python_single_target_python3_8
      (-)
?
,python_single_target_python3_9
      (-)
?
,python_single_target_python3_10
      (-)
?
]
>=dev-libs/template-glib-3.28.0[introspection]
>=x11-libs/vte-0.40.2:2.91[introspection]
>=net-libs/webkit-gtk-2.26:4=[introspection]
>=dev-libs/libxml2-2.9.0

git?
      ( dev-libs/libgit2:=[ssh,threads] >=dev-libs/libgit2-glib-0.28.0.1[ssh] )

dev-libs/libpcre:3
dev-libs/libpcre2
>=dev-libs/gobject-introspection-1.54.0:=

python_single_target_python3_8?
      ( >=dev-python/pygobject-3.22.0:3[python_targets_python3_8
            (-)
      ] )

python_single_target_python3_9?
      ( >=dev-python/pygobject-3.22.0:3[python_targets_python3_9
            (-)
      ] )

python_single_target_python3_10?
      ( >=dev-python/pygobject-3.22.0:3[python_targets_python3_10
            (-)
      ] )

python_single_target_python3_8?
      ( dev-lang/python:3.8 >=dev-lang/python-exec-2:=[python_targets_python3_8] )

python_single_target_python3_9?
      ( dev-lang/python:3.9 >=dev-lang/python-exec-2:=[python_targets_python3_9] )

python_single_target_python3_10?
      ( dev-lang/python:3.10 >=dev-lang/python-exec-2:=[python_targets_python3_10] )

clang?
      ( sys-devel/clang:= )

devhelp?
      ( >=dev-util/devhelp-3.25.1:= )

glade?
      ( >=dev-util/glade-3.22.0:3.10= )

spell?
      ( >=app-text/gspell-1.8:0= app-text/enchant:2 )

sysprof?
      ( >=dev-util/sysprof-3.37.1:0/4[gtk] )