gpo.zugaina.org

Search Portage & Overlays:

dev-ruby/multi_json

A gem to provide swappable JSON backends

Screenshots

  • multi_json-1.9.2
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_ruby21 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • multi_json-1.9.2
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_ruby21 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: funtoo (distro)
  • multi_json-1.8.4
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby18 ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: funtoo (distro)
  • multi_json-1.8.4
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby18 ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • multi_json-1.6.1-r1
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • multi_json-1.6.1-r1
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: funtoo (distro)
  • multi_json-1.6.1
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: funtoo (distro)
  • multi_json-1.6.1
    ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • multi_json-1.5.0
    amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: funtoo (distro)
  • multi_json-1.5.0
    amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • multi_json-1.5.0
    amd64
    test elibc_FreeBSD ruby_targets_ruby19 ruby_targets_jruby doc test test

    View      Download      Browse     License: MIT   
    Overlay: zentoo (distro)

ChangeLog

# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.38 2014/04/05 23:39:34 mrueg Exp $

05 Apr 2014; Manuel Rüger <mrueg@gentoo.org> multi_json-1.5.0.ebuild,
multi_json-1.6.1-r1.ebuild, multi_json-1.6.1.ebuild, multi_json-1.8.4.ebuild,
multi_json-1.9.2.ebuild:
Remove ree18 and ruby18 target.

*multi_json-1.9.2 (03 Apr 2014)

03 Apr 2014; Hans de Graaff <graaff@gentoo.org> +multi_json-1.9.2.ebuild:
Version bump. Add ruby21, drop ruby18.

*multi_json-1.8.4 (13 Feb 2014)

13 Feb 2014; Hans de Graaff <graaff@gentoo.org> +multi_json-1.8.4.ebuild:
Version bump.

29 Jan 2014; Akinori Hattori <hattya@gentoo.org> multi_json-1.5.0.ebuild,
multi_json-1.6.1-r1.ebuild, multi_json-1.6.1.ebuild:
keyword ~ia64 wrt bug #468536

22 Dec 2013; Anthony G. Basile <blueness@gentoo.org>
multi_json-1.6.1-r1.ebuild:
Keyword ~ppc64, bug #465948

*multi_json-1.6.1-r1 (25 Oct 2013)

25 Oct 2013; Hans de Graaff <graaff@gentoo.org> +multi_json-1.6.1-r1.ebuild:
Add ruby20. Drop ppc64 due to yard dependency, bug 465948.

25 Aug 2013; Hans de Graaff <graaff@gentoo.org> -multi_json-1.0.4.ebuild:
Cleanup. There is no need to keep old versions around since multi_json
adheres to semantic versioning.

*multi_json-1.0.4 (23 Aug 2013)

23 Aug 2013; Rick Farina <zerochaos@gentoo.org> +multi_json-1.0.4.ebuild:
reintroducing 1.0.4, needed as a dep for metasploit

27 Jul 2013; Agostino Sarubbo <ago@gentoo.org> multi_json-1.5.0.ebuild:
Stable for x86, wrt bug #477364

21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> multi_json-1.5.0.ebuild:
Stable for amd64, wrt bug #477364

19 Jul 2013; Hans de Graaff <graaff@gentoo.org> -multi_json-1.3.6.ebuild,
-multi_json-1.3.7.ebuild, -multi_json-1.4.0.ebuild:
Cleanup.

*multi_json-1.6.1 (18 Jul 2013)

18 Jul 2013; Hans de Graaff <graaff@gentoo.org> +multi_json-1.6.1.ebuild:
Version bump.

16 Jan 2013; Rick Farina <zerochaos@gentoo.org> multi_json-1.3.6.ebuild,
multi_json-1.3.7.ebuild, multi_json-1.4.0.ebuild, multi_json-1.5.0.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps

*multi_json-1.5.0 (25 Dec 2012)

25 Dec 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.5.0.ebuild:
Version bump.

*multi_json-1.4.0 (01 Dec 2012)

01 Dec 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.4.0.ebuild:
Version bump.

*multi_json-1.3.7 (11 Nov 2012)

11 Nov 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.3.7.ebuild:
Version bump.

28 Aug 2012; Hans de Graaff <graaff@gentoo.org> -multi_json-1.0.4.ebuild,
-multi_json-1.2.0.ebuild, -multi_json-1.3.4.ebuild, -multi_json-1.3.5.ebuild:
Cleanup.

*multi_json-1.3.6 (05 Jul 2012)

05 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +multi_json-1.3.6.ebuild:
Version bump, use the new rspec support.

*multi_json-1.3.5 (17 May 2012)

17 May 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.3.5.ebuild:
Version bump.

*multi_json-1.3.4 (07 May 2012)

07 May 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.3.4.ebuild:
Version bump.

01 May 2012; Raúl Porcel <armin76@gentoo.org> multi_json-1.0.4.ebuild,
multi_json-1.2.0.ebuild:
Drop ia64/sparc keywords

*multi_json-1.2.0 (09 Apr 2012)

09 Apr 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.2.0.ebuild:
Version bump.

09 Apr 2012; Hans de Graaff <graaff@gentoo.org> -multi_json-0.0.4.ebuild,
-multi_json-1.0.2.ebuild, -multi_json-1.0.3.ebuild:
Remove old versions.

11 Mar 2012; Brent Baude <ranger@gentoo.org> multi_json-1.0.4.ebuild:
Marking multi_json-1.0.4 ~ppc64 for bug 396043

07 Mar 2012; Naohiro Aota <naota@gentoo.org> multi_json-1.0.4.ebuild:
Add ~x86-fbsd.

06 Feb 2012; Brent Baude <ranger@gentoo.org> multi_json-1.0.4.ebuild:
Marking multi_json-1.0.4 ~ppc for bug 396043

19 Jan 2012; Jeroen Roovers <jer@gentoo.org> multi_json-1.0.4.ebuild:
Marked ~hppa (bug #396043).

08 Jan 2012; Fabian Groffen <grobian@gentoo.org> multi_json-1.0.4.ebuild:
Added Prefix keywords

27 Dec 2011; Hans de Graaff <graaff@gentoo.org> multi_json-1.0.4.ebuild:
Also require rspec:2 with USE=doc since it is required for the Rakefile.

26 Dec 2011; Fabian Groffen <grobian@gentoo.org> multi_json-1.0.4.ebuild:
Add Prefix keywords, bug #396043

*multi_json-1.0.4 (01 Dec 2011)

01 Dec 2011; Hans de Graaff <graaff@gentoo.org> +multi_json-1.0.4.ebuild:
Version bump.

05 Nov 2011; Hans de Graaff <graaff@gentoo.org> multi_json-1.0.3.ebuild:
dev-ruby/yajl-ruby is mandatory when testing for all targets except jruby.

*multi_json-1.0.3 (19 Jul 2011)

19 Jul 2011; Hans de Graaff <graaff@gentoo.org> +multi_json-1.0.3.ebuild,
+files/multi_json-1.0.3-gentoo.patch:
Version bump.

*multi_json-1.0.2 (24 May 2011)

24 May 2011; Hans de Graaff <graaff@gentoo.org> +multi_json-1.0.2.ebuild:
Version bump.

02 Oct 2010; Hans de Graaff <graaff@gentoo.org> multi_json-0.0.4.ebuild:
Remove bundler code because it requires all optional dependencies to be
installed. Fix RSpec dependency.

*multi_json-0.0.4 (19 Jun 2010)

19 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-multi_json-0.0.3-r1.ebuild, -files/multi_json-0.0.3-gentoo.patch,
+multi_json-0.0.4.ebuild, +files/multi_json-0.0.4-gentoo.patch:
Version bump, reduce patching to our tests' hacks.

*multi_json-0.0.3-r1 (19 Jun 2010)

19 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-multi_json-0.0.3.ebuild, +multi_json-0.0.3-r1.ebuild,
files/multi_json-0.0.3-gentoo.patch:
Fix issue #1 from upstream, json engine failed to work as itnended.

*multi_json-0.0.3 (19 Jun 2010)

19 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+multi_json-0.0.3.ebuild, +files/multi_json-0.0.3-gentoo.patch,
+metadata.xml:
Initial import of multi_json needed for the new version of oauth2. The
tests are particularly patched (and not all of it is upstreamed yet) so
that they pass on Ruby 1.9 and JRuby properly.