gpo.zugaina.org

Search Portage & Overlays:

dev-ruby/kramdown

Yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition

Screenshots

  • kramdown-1.2.0-r1
    ~amd64 ~arm ~x86
    latex elibc_FreeBSD ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_ruby21 doc test test

    View      Download      Browse     License: MIT   
    Overlay: funtoo (distro)
  • kramdown-1.2.0-r1
    ~amd64 ~arm ~x86
    latex elibc_FreeBSD ruby_targets_ruby19 ruby_targets_ruby20 ruby_targets_ruby21 doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • kramdown-0.14.2
    ~amd64 ~x86
    latex elibc_FreeBSD ruby_targets_ruby18 ruby_targets_ruby19 ruby_targets_jruby doc test test

    View      Download      Browse     License: GPL-3   
    Overlay: gentoo (distro)
  • kramdown-0.14.2
    ~amd64 ~x86
    latex elibc_FreeBSD ruby_targets_ruby18 ruby_targets_ruby19 ruby_targets_jruby doc test test

    View      Download      Browse     License: GPL-3   
    Overlay: funtoo (distro)

ChangeLog

# ChangeLog for dev-ruby/kramdown
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.32 2014/04/19 12:56:15 graaff Exp $

19 Apr 2014; Hans de Graaff <graaff@gentoo.org> kramdown-1.2.0-r1.ebuild:
Add ruby21.

09 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -kramdown-1.1.0.ebuild,
-kramdown-1.2.0.ebuild, kramdown-0.14.2.ebuild:
Cleanup old. Remove ree18.

*kramdown-1.2.0-r1 (30 Oct 2013)

30 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +kramdown-1.2.0-r1.ebuild:
Add ruby20 target.

05 Oct 2013; Hans de Graaff <graaff@gentoo.org> +kramdown-0.14.2.ebuild:
Add back a version that still has jruby in USE_RUBY, fixing bug 486986.

04 Oct 2013; Manuel Rüger <mrueg@gentoo.org> -kramdown-0.14.2.ebuild,
-kramdown-1.0.2.ebuild:
Cleanup old.

*kramdown-1.2.0 (03 Sep 2013)

03 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +kramdown-1.2.0.ebuild:
Version bump.

24 Aug 2013; Markus Meier <maekke@gentoo.org> kramdown-1.0.2.ebuild:
add ~x86, bug #478294

24 Aug 2013; Markus Meier <maekke@gentoo.org> kramdown-1.1.0.ebuild:
add ~x86, bug #478294

08 Aug 2013; Markus Meier <maekke@gentoo.org> kramdown-1.1.0.ebuild:
add ~arm, bug #477648

*kramdown-1.1.0 (14 Jul 2013)

14 Jul 2013; Manuel Rüger <mrueg@gentoo.org> +kramdown-1.1.0.ebuild:
Version bump

*kramdown-1.0.2 (29 May 2013)

29 May 2013; Hans de Graaff <graaff@gentoo.org> +kramdown-1.0.2.ebuild:
Version bump, thanks to mrueg in the ruby overlay.

05 May 2013; Hans de Graaff <graaff@gentoo.org> -kramdown-0.14.1.ebuild:
Cleanup.

*kramdown-0.14.2 (12 Mar 2013)

12 Mar 2013; Hans de Graaff <graaff@gentoo.org> +kramdown-0.14.2.ebuild:
Version bump.

12 Mar 2013; Hans de Graaff <graaff@gentoo.org> -kramdown-0.13.8.ebuild,
-kramdown-0.14.0.ebuild:
Cleanup.

*kramdown-0.14.1 (01 Dec 2012)

01 Dec 2012; Hans de Graaff <graaff@gentoo.org> +kramdown-0.14.1.ebuild:
Version bump. Add missing htmltidy test dependency thanks to mrueg.

*kramdown-0.14.0 (16 Sep 2012)

16 Sep 2012; Diego E. Pettenò <flameeyes@gentoo.org> +kramdown-0.14.0.ebuild:
Version bump.

*kramdown-0.13.8 (01 Sep 2012)

01 Sep 2012; Diego E. Pettenò <flameeyes@gentoo.org> +kramdown-0.13.8.ebuild,
-kramdown-0.13.7.ebuild:
Version bump; make sure latex dependencies are also added during test with the
flag enabled; use the rdoc recipe for documentation building.

25 Aug 2012; Hans de Graaff <graaff@gentoo.org> -kramdown-0.13.3.ebuild,
-kramdown-0.13.4.ebuild, -kramdown-0.13.5.ebuild, -kramdown-0.13.5-r1.ebuild,
-kramdown-0.13.6.ebuild:
Cleanup.

*kramdown-0.13.7 (04 Jun 2012)

04 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> +kramdown-0.13.7.ebuild:
Version bump.

12 May 2012; Alex Legler <a3li@gentoo.org> kramdown-0.13.5-r1.ebuild,
kramdown-0.13.6.ebuild:
Keyword ~x86, bug 407765

*kramdown-0.13.6 (10 May 2012)

10 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> +kramdown-0.13.6.ebuild:
Version bump.

*kramdown-0.13.5-r1 (11 Mar 2012)

11 Mar 2012; Hans de Graaff <graaff@gentoo.org> +kramdown-0.13.5-r1.ebuild:
Add latex USE flag to pull in the proper dependencies for latex support. Also
fix tests when not all latex dependencies are installed.

*kramdown-0.13.5 (27 Feb 2012)

27 Feb 2012; Diego E. Pettenò <flameeyes@gentoo.org> +kramdown-0.13.5.ebuild:
Version bump.

*kramdown-0.13.4 (18 Dec 2011)

18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +kramdown-0.13.4.ebuild:
Version bump. Add ruby19. Require new enough version of coderay for tests.
It's optional but we need at least this version.

19 Jun 2011; Hans de Graaff <graaff@gentoo.org> kramdown-0.13.3.ebuild:
Only generate docs when USE=doc. Fixes bug 372189, thanks to Kai Dietrich for
the proposed fix.

19 Jun 2011; Hans de Graaff <graaff@gentoo.org> -kramdown-0.13.2.ebuild:
Remove old version.

*kramdown-0.13.3 (06 May 2011)

06 May 2011; Hans de Graaff <graaff@gentoo.org> +kramdown-0.13.3.ebuild:
Version bump.

06 May 2011; Hans de Graaff <graaff@gentoo.org> -kramdown-0.11.0.ebuild,
-kramdown-0.12.0.ebuild, -kramdown-0.13.1.ebuild:
Remove old versions.

*kramdown-0.13.2 (25 Feb 2011)

25 Feb 2011; Hans de Graaff <graaff@gentoo.org> +kramdown-0.13.2.ebuild:
Version bump.

*kramdown-0.13.1 (23 Jan 2011)

23 Jan 2011; Hans de Graaff <graaff@gentoo.org> +kramdown-0.13.1.ebuild:
Version bump.

*kramdown-0.12.0 (07 Nov 2010)

07 Nov 2010; Hans de Graaff <graaff@gentoo.org> +kramdown-0.12.0.ebuild:
Version bump.

*kramdown-0.11.0 (16 Oct 2010)

16 Oct 2010; Hans de Graaff <graaff@gentoo.org> +kramdown-0.11.0.ebuild,
+metadata.xml:
Initial import. This is a mandatory dependency of app-text/webgen, bug
341067.