gpo.zugaina.org

Search Portage & Overlays:

dev-python/pyatspi

Python binding to at-spi library

Screenshots

  • pyatspi-9999
    python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: gnome (layman)
  • pyatspi-2.31.1
    ~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86
    python_targets_python3_5 python_targets_python3_6 python_targets_python3_7

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: gnome-next (layman)
  • pyatspi-2.26.0
    ~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86
    python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: gentoo (distro)
  • pyatspi-2.26.0
    ~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86
    python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: gnome (layman)
  • pyatspi-2.24.0
    ~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 sparc x86
    python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: gentoo (distro)
  • pyatspi-2.12.0-r1000
    *
    python_abis_2.6 python_abis_2.7 python_abis_3.1 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 python_abis_3.6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: progress (layman)
  • pyatspi-2.10.0-r1000
    *
    python_abis_2.6 python_abis_2.7 python_abis_3.1 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 python_abis_3.6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: progress (layman)
  • pyatspi-2.8.0-r1000
    *
    python_abis_2.6 python_abis_2.7 python_abis_3.1 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 python_abis_3.6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: progress (layman)
  • pyatspi-2.6.0-r1000
    *
    python_abis_2.6 python_abis_2.7 python_abis_3.1 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 python_abis_3.6

    View      Download      Browse     License: LGPL-2 GPL-2+   
    Overlay: progress (layman)

ChangeLog

commit 97e630310725958329cc984c6a62aa5a532bb243
Author: Cynede <cynede@gentoo.org>
Date: Thu Jan 10 14:14:44 2019 +0400

pyatspi bump

commit 0f495970a23b8bd870b516452259a1b1d9f5d5d0
Author: Cynede <cynede@gentoo.org>
Date: Mon Sep 10 12:25:08 2018 +0400

Major overlay rework:
- Supported python: 3.5 3.6 and 3.7
- Bump networkmanager, webkit-gtk
- Bump and fix gtk-doc
- Clean up outdated unused stuff

commit b71ff73e8a9fa019e43bfbe937449f5c648a7d36
Author: Cynede <cynede@gentoo.org>
Date: Tue Sep 4 12:20:16 2018 +0400

pyatspi bump / py 3.7 support

commit 21d97124b804a72110b3f2cbd54ab8b6b9522bf3
Author: Cynede <cynede@gentoo.org>
Date: Tue Aug 14 09:55:39 2018 +0400

various gnome 3.29.91 libs bumps

commit 1ad7d23cdcf5086f4e13e7824914acd55602df01
Author: Cynede <cynede@gentoo.org>
Date: Tue Jun 19 12:29:39 2018 +0400

pyatspi bump

commit ccfdd0d1801920ad6d98f40159d01fb879fd3dbb
Author: Alessandro Rosetti <alessandro.rosetti@gmail.com>
Date: Wed Sep 13 18:25:59 2017 +0200

gnome-3.26 bump all bumpable ebuilds

commit 0a52b8e2843ea10b0c17c153a0be9ba2d4d44a2b
Author: Mikhail Pukhlikov <cynede@gentoo.org>
Date: Tue Jun 20 11:42:05 2017 +0400

3.25.3 packages: glib, eog, eog-plugins, at-spi stuff, calc, builder, gnome-desktop

commit 396865c4cab6c150d8433a98bb4eec928145af3d
Author: Mikhail Pukhlikov <cynede@gentoo.org>
Date: Tue May 23 12:04:04 2017 +0400

some more 3.25.2 parts, pango 1.40.6

commit 4660dca570d99bb16a85a1400f7bc2624d07159d
Author: Mikhail Pukhlikov <cynede@gentoo.org>
Date: Tue Mar 21 10:41:06 2017 +0400

at-spi bumps

commit b22d3ca85cebde124374d4e1da8d22c950cf539b
Author: Heather <heather@live.ru>
Date: Fri Aug 28 15:04:04 2015 +0400

clean everything

commit 8292733225c86087aa2b66d5749eebd84b52e313
Author: Hristo Venev <hristo@venev.name>
Date: Tue Apr 22 18:03:35 2014 +0300

gnome3.eclass: first batch of ebuilds

And add python3_4 support

commit da576937c3314a56b0bb8206b897f107dba22fc0
Author: Heather <Heather@live.ru>
Date: Wed Feb 26 13:55:44 2014 +0400

at spi bumps

commit 402fb79024123a1279cd6ee99eb6578768fbf622
Author: Heather <Heather@live.ru>
Date: Tue Dec 24 13:23:33 2013 +0400

JUST MELD changes from official gnome overlay

commit 21bfdff1cf475246fbe8cab132244c02e561beae
Author: Tom Wijsman <TomWij@live.com>
Date: Fri Nov 15 02:35:26 2013 +0100

Added missing metadata.xml.

Package-Manager: portage-HEAD
Manifest-Sign-Key: 6D34E57D

commit 146a75130cfd964e6dada20ec2099a7135c09fd9
Author: Fabio Erculiani <lxnay@sabayon.org>
Date: Wed Nov 13 07:41:44 2013 +0100

overlay: drop all 9999 ebuilds, they're completely out of sync

commit 5927d9f4b7ce43bf85acbf13bb462a9e41f8b850
Author: Heather <Heather@cynede.net>
Date: Wed Oct 9 15:33:05 2013 +0400

pyatspi 2.10.0

commit d58194c2c40749043ff4b9ff25e87ed28659a076
Author: Gilles Dartiguelongue <eva@gentoo.org>
Date: Sat Oct 27 10:56:24 2012 +0200

*/*: update to thin-manifests

Thin manifests only track dist files, since git tracks ebuilds and
patches, this is fine. It also reduces merge/rebase problems.

commit ac4c2a092c07bdef9c9a0228fb169f22ddb5b7f2
Author: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Wed Oct 17 00:35:15 2012 -0400

dev-python/pyatspi: sync with gx86

Disable non-functional test suite, as pointed out my Matt Turner.

commit 738b7a3748002d6b745eb521e9dbb9103ba09731
Author: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Tue Sep 25 19:29:39 2012 -0400

x11-libs/gtk+, x11-themes/gnome-themes-standard, at-spi2-*: now in gx86

Sync live ebuilds with gx86.

commit 9c177c41c7709f0dd310d8f19d9eabc59d16c059
Author: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Thu May 24 04:26:19 2012 -0400

dev-python/pyatspi: update

commit e51996487b8b8d01d1b59a5e317f5a0d5f8cb8e7
Author: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Sun May 6 03:13:45 2012 -0400

dev-util/pkgconfig → virtual/pkgconfig

commit df53bea17ae8ba2154607387d414cf916f05935d
Author: Priit Laes <plaes@plaes.org>
Date: Fri Feb 10 10:06:04 2012 +0200

Bump minimum Python requirement to 2.5

commit 7b4d8141b77b90f1bec24f97bdcc6fe7431eceb7
Author: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Sat Nov 5 19:52:34 2011 -0400

lots of packages: moved to gx86

commit eac0036a837e86c6910b463ee0301a5dd76002f5
Author: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Fri Nov 4 17:20:16 2011 -0400

lots of packages: qa

Port to EAPI4 where appropriate.
Let the eclass take care of maintainer mode.
Add missing python_* calls to pkg_setup.

commit 9cbc374037160a2e5b977da6d65ff3ecfa2afd5c
Author: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Sun Oct 23 04:15:32 2011 -0400

dev-python/pyatspi: 2.2.0 → 2.2.1

Bump with a minor performance improvement.

commit 9b522f73464e42c18534e5c1c5f569dc28a955b6
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Mon Oct 3 16:49:07 2011 -0400

dev-python/pyatspi: do not check for pygtk

Upstream bug filed at https://bugzilla.gnome.org/show_bug.cgi?id=660826
Reported on IRC by Arc Riley of pysoy.

commit 5a673b1d331462c4b134f106787f7ec884b27216
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Sun Oct 2 02:50:46 2011 -0400

dev-python/pyatspi: depend on at-spi2-core-$

As noted by Fabio Erculiani (lxnay), pyatspi is tightly coupled with
at-spi2-core API changes in the corresponing version, despite the lack
of any sort of build-time version check. Using pyatspi with an older
version of at-spi2-core results in runtime crashes.

commit 80020ae2a9466df96c4a971c7f2501b8967d1983
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Tue Sep 27 18:35:48 2011 -0400

dev-python/pyatspi: 2.1.90 → 2.2.0

Bump and add live ebuild.

commit a54c8589a29917fbd829bb49ad22db4e932a728d
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Tue Aug 30 00:11:55 2011 -0400

dev-python/pyatspi: 2.1.5 → 2.1.90

Version bump, brings full pygobject:3 compatibility. Patch applied
upstream.

commit 406e4a4d8cb39dbb06748a30a78a4b96117e4071
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Tue Aug 16 14:43:32 2011 -0400

dev-python/pyatspi: 2.1.4 → 2.1.5

Version bump with minor changes; add an upstream patch to add missing
quotes at the end of a documentation string.

commit 8cea3a4b55a56de8e5ed151668d358108aa81379
Author: Nirbheek Chauhan <nirbheek@gentoo.org>
Date: Tue Aug 16 19:06:44 2011 +0530

caribou, pyatspi: fix deps

commit c7f1ed244aeefa9cb08089c77d6c20cb8b0ed3b9
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Tue Jul 26 03:18:23 2011 -0400

dev-python/pyatspi: 2.0.2 → 2.1.4

Bump to gnome-3.1.x version, update dependencies.

commit d6b89277112a0d8e951edc36558e52641c4d373f
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Tue Jul 26 03:01:22 2011 -0400

dev-python/pyatspi: qa

Fix dependencies (dbus-python is a required buildtime and runtime
dependency; dbus is always required at runtime). Builds and passes
tests on x86.

commit fac312790f8c83d7e7a5d7d53d32027eceacdc66
Author: Alexandre Rostovtsev <tetromino@gmail.com>
Date: Fri May 27 02:51:12 2011 -0400

dev-python/pyatspi: 2.0.1 → 2.0.2

Signed-off-by: Nirbheek Chauhan <nirbheek@gentoo.org>

commit 34e5047c19bd01b588468b7a31619887a7d6fa21
Author: Gilles Dartiguelongue <eva@gentoo.org>
Date: Wed Apr 27 23:40:46 2011 +0200

dev-python/pyatspi: 2.0.0 → 2.0.1

commit 43d74b579decd69cb22a1aab99c4dee92ec498c0
Author: Gilles Dartiguelongue <eva@gentoo.org>
Date: Thu Apr 14 21:35:38 2011 +0200

dev-python/pyatspi: initial commit