gpo.zugaina.org

Search Portage & Overlays:

dev-python/maxminddb

Python MaxMind DB reader extension

Screenshots

  • maxminddb-9999
    python_targets_pypy3 python_targets_python3_8 python_targets_python3_9

    View      Download      Browse     License: Apache-2.0   
    Overlay: raiagent
  • maxminddb-2.2.0
    ~amd64 ~x86
    python_targets_python3_8 python_targets_python3_9 python_targets_python3_10 python_targets_python3_11

    View      Download      Browse     License: BSD   
    Overlay: fritteli
  • maxminddb-1.5.2
    amd64 ~ia64 ~ppc ~sparc x86
    python_targets_pypy3 python_targets_python3_9 python_targets_python3_10

    View      Download      Browse     License: Apache-2.0   
    Overlay: pentoo
  • maxminddb-1.5.1
    ~amd64 ~x86
    python_targets_pypy3 python_targets_python3_8 python_targets_python3_9

    View      Download      Browse     License: Apache-2.0   
    Overlay: raiagent

ChangeLog

commit d29227d9fbb97f0d26b03035d5e1c7b9f403271a
Author: leycec <leycec@gmail.com>
Date: Tue Sep 29 14:43:39 2020 -0400

Python 3.9 support.

This commit adds provisional support for Python 3.9 to all
Python-centric ebuilds currently supporting Python 3.6 through 3.8.
Unrelatedly, this commit both removes all obsolete BETSEE ebuilds and
adds support for PyPy3 to both BETSE and BETSEE ebuilds.

commit b0dba311b5eae247ce79c9596bbb43ed4f0ed1a2
Author: leycec <leycec@gmail.com>
Date: Wed Feb 26 01:27:23 2020 -0500

dev-python/*: Python 2.7 removal.

This commit removes most Python 2.7 support from Python-centric
packages, excluding high-profile packages (e.g., Powerline) for which
end users typically still expect or require such support. Unrelatedly,
this commit also restores symlinks accidentally flattened by a prior
commit (whose SHA-1 shall remain nameless).

commit 7b32e2d7975a5a20737ae8b38cc089bcaf643148
Author: leycec <leycec@gmail.com>
Date: Fri Jan 24 01:14:11 2020 -0500

dev-python/*: $ sanitized.

This commit sanitizes the $ global required by all Python
ebuilds by removing references to obsolete Python interpreters.

commit 6a43c905624f32705530f4ea695aa091adba77f0
Author: leycec <leycec@gmail.com>
Date: Fri Nov 15 23:52:44 2019 -0500

dev-python/*: Python 3.8 supported.

This commit adds Python 3.8 support to all existing "dev-python"
packages in this repository under the generally safe assumption that all
packages already supporting Python 3.7 will also support Python 3.8.
Packages failing to do so will, of course, be reverted as needed.

commit 4109cc37caa7c930589b891d082c837add794dbf
Author: leycec <leycec@gmail.com>
Date: Wed Oct 2 01:09:37 2019 -0400

dev-python/*: $.

Most Python packages now require "setuptools" via the EAPI 7-specific
$ variable rather than the $ variable, in compliance
with cross-compiler sanity.

commit 055a7ea4cdbac1eac2e7b1cb1b5120623fa7605f
Author: leycec <leycec@gmail.com>
Date: Tue Oct 1 01:15:09 2019 -0400

dev-python/python-bitcoinlib: 0.10.2 added.

This commit adds both the most recent stable and live releases of
"python-bitcoinlib", a new mandatory dependency of ZeroNet >= 0.7.0.

commit 3c599615309b02eadf3004987f35bd70e5d7120a
Author: leycec <leycec@gmail.com>
Date: Mon Sep 30 21:08:36 2019 -0400

dev-python/maxminddb: 1.5.1 added.

This commit adds both the most recent stable and live releases of
"maxminddb", a new mandatory dependency of ZeroNet >= 0.7.0.

Unrelatedly, various "dev-python/*/metadata.xml" files have been
truncated for brevity and maintainability.