gpo.zugaina.org

Search Portage & Overlays:

dev-ruby/travis

Travis CI Client (CLI and Ruby library)

Screenshots

  • travis-1.10.0
    ~amd64
    test ruby_targets_ruby25 ruby_targets_ruby26 doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo
  • travis-1.10.0
    ~amd64
    test ruby_targets_ruby25 ruby_targets_ruby26 doc test test

    View      Download      Browse     License: MIT   
    Overlay: ferki
  • travis-1.9.1
    ~amd64
    test ruby_targets_ruby24 ruby_targets_ruby25 ruby_targets_ruby26 doc test test

    View      Download      Browse     License: MIT   
    Overlay: gentoo

Runtime Dependencies

travis-1.10.0

dev-vcs/git

ruby_targets_ruby25?
      ( dev-ruby/faraday:1[ruby_targets_ruby25
            (-)
      ] dev-ruby/faraday_middleware:1[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/gh-0.17[ruby_targets_ruby25
            (-)
      ] dev-ruby/highline:2[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/json-2.3:2[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/launchy-2.1[ruby_targets_ruby25
            (-)
      ] >dev-ruby/pusher-client-0.4[ruby_targets_ruby25
            (-)
      ] dev-ruby/typhoeus:0[ruby_targets_ruby25
            (-)
      ] )

ruby_targets_ruby26?
      ( dev-ruby/faraday:1[ruby_targets_ruby26
            (-)
      ] dev-ruby/faraday_middleware:1[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/gh-0.17[ruby_targets_ruby26
            (-)
      ] dev-ruby/highline:2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/json-2.3:2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/launchy-2.1[ruby_targets_ruby26
            (-)
      ] >dev-ruby/pusher-client-0.4[ruby_targets_ruby26
            (-)
      ] dev-ruby/typhoeus:0[ruby_targets_ruby26
            (-)
      ] )

ruby_targets_ruby25?
      ( dev-lang/ruby:2.5 )

ruby_targets_ruby26?
      ( dev-lang/ruby:2.6 )

ruby_targets_ruby25?
      ( virtual/rubygems[ruby_targets_ruby25
            (-)
      ] )

ruby_targets_ruby26?
      ( virtual/rubygems[ruby_targets_ruby26
            (-)
      ] )

travis-1.10.0

dev-vcs/git

ruby_targets_ruby25?
      ( dev-ruby/faraday:1[ruby_targets_ruby25
            (-)
      ] dev-ruby/faraday_middleware:1[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/gh-0.17[ruby_targets_ruby25
            (-)
      ] dev-ruby/highline:2[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/json-2.3:2[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/launchy-2.1[ruby_targets_ruby25
            (-)
      ] >dev-ruby/pusher-client-0.4[ruby_targets_ruby25
            (-)
      ] )

ruby_targets_ruby26?
      ( dev-ruby/faraday:1[ruby_targets_ruby26
            (-)
      ] dev-ruby/faraday_middleware:1[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/gh-0.17[ruby_targets_ruby26
            (-)
      ] dev-ruby/highline:2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/json-2.3:2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/launchy-2.1[ruby_targets_ruby26
            (-)
      ] >dev-ruby/pusher-client-0.4[ruby_targets_ruby26
            (-)
      ] )

ruby_targets_ruby25?
      ( dev-lang/ruby:2.5 )

ruby_targets_ruby26?
      ( dev-lang/ruby:2.6 )

ruby_targets_ruby25?
      ( virtual/rubygems[ruby_targets_ruby25
            (-)
      ] )

ruby_targets_ruby26?
      ( virtual/rubygems[ruby_targets_ruby26
            (-)
      ] )

travis-1.9.1

dev-vcs/git

ruby_targets_ruby24?
      ( dev-ruby/faraday:1[ruby_targets_ruby24
            (-)
      ] dev-ruby/faraday_middleware:1[ruby_targets_ruby24
            (-)
      ] >=dev-ruby/gh-0.17[ruby_targets_ruby24
            (-)
      ] dev-ruby/highline:2[ruby_targets_ruby24
            (-)
      ] >=dev-ruby/json-2.3:2[ruby_targets_ruby24
            (-)
      ] >=dev-ruby/launchy-2.1[ruby_targets_ruby24
            (-)
      ] >dev-ruby/pusher-client-0.4[ruby_targets_ruby24
            (-)
      ] dev-ruby/typhoeus:0[ruby_targets_ruby24
            (-)
      ] )

ruby_targets_ruby25?
      ( dev-ruby/faraday:1[ruby_targets_ruby25
            (-)
      ] dev-ruby/faraday_middleware:1[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/gh-0.17[ruby_targets_ruby25
            (-)
      ] dev-ruby/highline:2[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/json-2.3:2[ruby_targets_ruby25
            (-)
      ] >=dev-ruby/launchy-2.1[ruby_targets_ruby25
            (-)
      ] >dev-ruby/pusher-client-0.4[ruby_targets_ruby25
            (-)
      ] dev-ruby/typhoeus:0[ruby_targets_ruby25
            (-)
      ] )

ruby_targets_ruby26?
      ( dev-ruby/faraday:1[ruby_targets_ruby26
            (-)
      ] dev-ruby/faraday_middleware:1[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/gh-0.17[ruby_targets_ruby26
            (-)
      ] dev-ruby/highline:2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/json-2.3:2[ruby_targets_ruby26
            (-)
      ] >=dev-ruby/launchy-2.1[ruby_targets_ruby26
            (-)
      ] >dev-ruby/pusher-client-0.4[ruby_targets_ruby26
            (-)
      ] dev-ruby/typhoeus:0[ruby_targets_ruby26
            (-)
      ] )

ruby_targets_ruby24?
      ( dev-lang/ruby:2.4 )

ruby_targets_ruby25?
      ( dev-lang/ruby:2.5 )

ruby_targets_ruby26?
      ( dev-lang/ruby:2.6 )

ruby_targets_ruby24?
      ( virtual/rubygems[ruby_targets_ruby24
            (-)
      ] )

ruby_targets_ruby25?
      ( virtual/rubygems[ruby_targets_ruby25
            (-)
      ] )

ruby_targets_ruby26?
      ( virtual/rubygems[ruby_targets_ruby26
            (-)
      ] )