gpo.zugaina.org

Search Portage & Overlays:

sci-mathematics/sage

Math software for abstract and numerical computations

Screenshots

  • sage-9999
    debug html latex pdf sagenb testsuite X modular_decomposition bliss linguas_ca linguas_de linguas_en linguas_fr linguas_hu linguas_it linguas_ja linguas_pt linguas_ru linguas_tr python_targets_python2_7

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)
  • sage-7.2-r1
    ~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos
    +bin-html bin-pdf debug html latex manifolds pdf sagenb testsuite X modular_decomposition bliss linguas_ca linguas_de linguas_en linguas_fr linguas_hu linguas_it linguas_ja linguas_pt linguas_ru linguas_tr python_targets_python2_7

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)
  • sage-7.2
    ~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos
    +bin-html bin-pdf debug html latex pdf sagenb testsuite X modular_decomposition bliss linguas_ca linguas_de linguas_en linguas_fr linguas_hu linguas_it linguas_ja linguas_pt linguas_ru linguas_tr python_targets_python2_7

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)
  • sage-7.1-r1
    ~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos
    latex testsuite debug X manifolds +bin-html bin-pdf html pdf pdf modular_decomposition bliss linguas_ca linguas_de linguas_en linguas_fr linguas_hu linguas_it linguas_ja linguas_pt linguas_ru linguas_tr python_targets_python2_7

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)
  • sage-7.1
    ~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos
    latex testsuite debug X +bin-html bin-pdf html pdf pdf modular_decomposition bliss linguas_ca linguas_de linguas_en linguas_fr linguas_hu linguas_it linguas_ja linguas_pt linguas_ru linguas_tr python_targets_python2_7

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)
  • sage-7.0-r1
    ~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos
    latex testsuite debug X manifolds +bin-html bin-pdf html pdf modular_decomposition bliss linguas_ca linguas_de linguas_en linguas_fr linguas_hu linguas_it linguas_ja linguas_pt linguas_ru linguas_tr python_targets_python2_7

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)
  • sage-7.0
    ~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos
    latex testsuite debug X +bin-html bin-pdf html pdf modular_decomposition bliss linguas_ca linguas_de linguas_en linguas_fr linguas_hu linguas_it linguas_ja linguas_pt linguas_ru linguas_tr python_targets_python2_7

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)

ChangeLog

# ChangeLog for sci-mathematics/sage
# Copyright 1999-2016 Gentoo Foundation; Distributed under the GPL v2
# $Header: $

25 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.3-exec.patch, sage-9999.ebuild:
sci-mathematics/sage: bump patch for 7.3.beta1

24 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.3-singular.patch, sage-7.0-r1.ebuild, sage-7.0.ebuild,
sage-7.1-r1.ebuild, sage-7.1.ebuild, sage-7.2-r1.ebuild, sage-7.2.ebuild,
sage-9999.ebuild:
sci-mathematics/sage: work on libsingular dependency, still have the -DNDEBUG
issue

22 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: Remove a sed now useless and better document a patch

21 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.3-neutering.patch, +files/sage-7.3-safepython.patch,
sage-9999.ebuild:
sci-mathematics/sage: bump atches and dependencies for 7.3.beta0

18 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-6.10-blas.patch, -files/sage-6.8-singular_extra_arg.patch,
-sage-6.10.ebuild:
sci-mathematics/sage: remove 6.10

*sage-7.2-r1 (17 May 2016)

17 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-7.2-r1.ebuild:
sci-mathematics/sage: add a manifolds option in 7.2 for issue #407

*sage-7.2 (16 May 2016)

16 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-7.2.ebuild:
sci-mathematics/sage: Bump to 7.2

12 May 2016; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml:
sci-mathematics/sage: update metadata.xml for issue #421

11 May 2016; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml,
sage-9999.ebuild:
sci-mathematics/sage: make sage-notebook optional for 7.2+. This is now
officially a legacy program and sage doesn't depend on it anymore.

10 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump sagenb dependency

08 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.2-neutering.patch:
sci-mathematics/sage: cleaning the two failing doctests from the neutering
patch

07 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump dependency for 7.2.rc1

05 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.2-all.py.patch, files/sage-7.2-neutering.patch,
sage-9999.ebuild:
sci-mathematics/sage: bump patches for 7.2.rc0

04 May 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: Work on dependencies

30 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: re-allow multiple LINGUAS in this branch

30 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump cython dependency to 0.24 in sage-9999

28 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: fix merge from vbraun branch and disable building non-
english documentation.

27 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: dependency changes for latest snapshot

26 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.2-neutering.patch:
sci-mathematics/sage: WIP, changes to doctesting

25 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.2-neutering.patch, sage-9999.ebuild:
sci-mathematics/sage: work in progress on changes to doctesting

21 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: dependency bump for 7.2.beta5

16 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: correct repo for this branch

16 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: restore te right repo

12 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump for 7.2.beta4

12 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.2-singular.patch, -files/sage-7.2-singular_extra_arg.patch,
sage-9999.ebuild:
sci-mathematics/sage: preparation for 7.2.beta4

12 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.2-singular_extra_arg.patch:
sci-mathematics/sage: updating singular_extra_args patch

09 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.2-singular_extra_arg.patch, sage-9999.ebuild:
sci-mathematics/sage: updating patches

08 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.2-jupyter.patch, sage-9999.ebuild:
sci-mathematics/sage: updating jupyter patch for upcoming move of sphinxify.

07 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.2-exec.patch:
sci-mathematics/sage: bump patch for 7.2.beta3

02 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: gap 4.8.3 is functional enough but will go under more
scrutiny. Correcting the relative location of VERSION.txt

02 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.2-exec.patch, sage-9999.ebuild:
sci-mathematics/sage: bump for 7.2.beta2

25 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: depend on the right version of cysignals

25 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: update dependencies for 7.2.beta0

*sage-7.1-r1 (21 Mar 2016)

21 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-7.1-r1.ebuild:
sci-mathematics/sage: Add manifolds option to sage 7.1 in r1 for issue #407

*sage-7.1 (21 Mar 2016)

21 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-7.1.ebuild, -files/cython-0.23.3.patch,
-files/sage-6.6-ipython_kernel_start.patch, -files/sage-6.6-sagedoc.patch,
-files/sage-6.8-blas-r1.patch, -files/sage-6.9-neutering.patch,
-sage-6.9.ebuild, metadata.xml, sage-6.10.ebuild, sage-7.0.ebuild:
sci-mathematics/sage: sage 7.1 has landed

19 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.10.ebuild, sage-6.9.ebuild, sage-7.0-r1.ebuild, sage-7.0.ebuild,
sage-9999.ebuild:
sci-mathematics/sage: pin sympy version

*sage-7.0-r1 (14 Mar 2016)

14 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.0-manifolds.patch, +sage-7.0-r1.ebuild, metadata.xml:
sci-mathematics/sage: add a manifolds option for issue #407

10 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-7.1-blas.patch, files/sage-7.1-exec.patch,
files/sage-7.1-neutering.patch, sage-9999.ebuild:
sci-mathematics/sage: The one in which the blas patch disapear....

09 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: removing the pruning of _static folders lead to a
tripling of the install time locally, restoring.

08 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: Work around for issue #402 while I am scratching my head
on where it is coming from.

07 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: touching doc building again. Not solution in sight for
issue #402

06 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.1-linguas.patch, sage-9999.ebuild:
sci-mathematics/sage: small re-organzing of the doc. No impact on issue #402

03 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.1-neutering.patch, files/sage-7.1-sources.patch,
sage-9999.ebuild:
sci-mathematics/sage: bump patches and dependencies for sage 7.1.beta6

27 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-7.0.ebuild, sage-9999.ebuild:
sci-mathematics/sage: work on sage-notebook dependencies for issue #396, use
some new knoledge about location of sphinxify while working on upstream
tickets.

27 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/proto.sage-env-7.1, sage-9999.ebuild:
sci-mathematics/sage: for sage 7.1 sage-env will need SAGE_DOC_SRC

26 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: documentation should be all right now

26 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: More rumbling about documentation building

26 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.1-blas.patch, files/sage-7.1-env.patch,
files/sage-7.1-jupyter.patch, files/sage-7.1-linguas.patch,
files/sage-7.1-sagedoc.patch, files/sage-7.1-sources.patch, sage-9999.ebuild:
sci-mathematics/sage: bump patches and dependencies for 7.1.beta5

21 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-MPL-1.5.1.patch:
sci-mathematics/sage: update MPL-1.5.1 patch in line with decision reached for
sage 7.1

18 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-7.0.ebuild:
sci-mathematics/sage: improve sphinx dependency in stable to fix and close
#392

18 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.1-neutering.patch, sage-9999.ebuild:
sci-mathematics/sage: bump for 7.1.beta4

12 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: one doc too many

12 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: shipping more files for sagedoc.py

11 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-7.1-doc_common.patch, files/sage-7.1-sources.patch,
sage-9999.ebuild:
sci-mathematics/sage: fixing problems with links generated by the next
documentation ticket

11 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: correction for case of overzealous sed-ing

11 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.1-env.patch, files/sage-7.1-sagedoc.patch, sage-9999.ebuild:
sci-mathematics/sage: bump patch and dependency for 7.1.beta3

10 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.1-sagedoc.patch, sage-9999.ebuild:
sci-mathematics/sage: rip off the part that checks that html documentation is
built against the shipped rst files. Remove all rst files and doc/common
files are they are now unused.

10 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: re-add export MAKE=make for pdf doc

09 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.1-sagedoc.patch:
sci-mathematics/sage: getting rid of calls to sage_setup in sagedoc

09 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: re-instate installing rst files as they are required for
doctests.

09 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: more adjustments for 7.1.beta2

09 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: We have building of documention again in sage-9999

09 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.1-linguas.patch, sage-9999.ebuild:
sci-mathematics/sage: documentation still not building.

08 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-7.1-env.patch, sage-9999.ebuild:
sci-mathematics/sage: more changes for 7.1.beta1

08 Feb 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.1-doc_common.patch, +files/sage-7.1-env.patch,
+files/sage-7.1-exec.patch, +files/sage-7.1-linguas.patch,
+files/sage-7.1-sagedoc.patch, +files/sage-7.1-sources.patch,
files/sage-7.1-jupyter.patch, sage-9999.ebuild:
sci-mathematics/sage: patches updated. At this stage I don't expect the
documentation to build.

31 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml,
sage-6.10.ebuild, sage-6.9.ebuild, sage-7.0.ebuild, sage-9999.ebuild:
sci-mathematics/sage: change dep from libcliquer to cliquer

24 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.1-jupyter.patch, sage-9999.ebuild:
sci-mathematics/sage: bump for 7.1.beta0, probably needs ipython-notebook
fiddling.

22 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-5.9-fix-ostools-doctest.patch, files/sage-6.3-doc_common.patch,
files/sage-6.6-linguas.patch, sage-9999.ebuild:
sci-mathematics/sage: moving to EAPI 6

22 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-7.0.ebuild:
sci-mathematics/sage: correct ntl dependency and enforce strict version for
now

*sage-7.0 (20 Jan 2016)

20 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-7.0.ebuild, -files/cython-0.23.patch, -files/sage-6.8-exec.patch,
-sage-6.8-r2.ebuild:
sci-mathematics/sage: sage 7.0 is out

16 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-MPL-1.5.1.patch, sage-9999.ebuild:
sci-mathematics/sage: Make implicit_plot play nice with MPL 1.5.1 in sage 9999

13 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump pexpect dependency

02 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.10.ebuild, sage-6.8-r2.ebuild, sage-6.9.ebuild:
sci-mathematics/sage:

30 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-7.0-blas.patch, +files/sage-7.0-singular_extra_arg.patch,
sage-9999.ebuild:
sci-mathematics/sage: bump patches for 7.0.beta2

27 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: clean depedndencies. Make sagenb a build and runtime
dependency when building the doc. Runtim, so that it is implied from the
testsuite. May be I should refine that in the future.

25 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.10.ebuild, sage-6.8-r2.ebuild, sage-6.9.ebuild:
sci-mathematics/sage: pin ntl dependency in stable sage.

25 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump dependencies for 7.0.beta1

23 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump dependencies for 7.0.beta0

22 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.10.ebuild:
sci-mathematics/sage: Fix to close #386

20 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.10.ebuild, sage-6.8-r2.ebuild, sage-6.9.ebuild:
sci-mathematics/sage: fix pexpect version in stable branches

20 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: correct dependencies for the vbraun branch

20 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.10.ebuild, sage-6.8-r2.ebuild, sage-6.9.ebuild:
sci-mathematics/sage: current stable depend on sage-notebook 0.11.4

20 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/MPL-1.4.patch, -files/sage-6.0-all.py.patch,
-files/sage-6.2-pexpect.patch, -files/sage-6.3-noclean.patch,
-files/sage-6.4-givaro_singular_extra.patch, -files/sage-6.7-blas.patch,
-files/sage-6.7-env.patch, -files/sage-6.7-misc.patch:
sci-mathematics/sage: remove old patches

*sage-6.10 (20 Dec 2015)

20 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.10.ebuild, -sage-6.7-r2.ebuild, sage-9999.ebuild:
sci-mathematics/sage: 6.10 at last. Generating bin-pdf docs took an awful long
time.

13 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump numpy dependency

13 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.7-r2.ebuild, sage-6.8-r2.ebuild, sage-6.9.ebuild, sage-9999.ebuild:
sci-mathematics/sage: adjust dependency to flintqs to use the newest version,
which is just a re-packaging.

09 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.10-blas.patch:
sci-mathematics/sage: the updated blas patch is now usable

09 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.10-blas.patch, sage-6.7-r2.ebuild, sage-6.8-r2.ebuild,
sage-6.9.ebuild, sage-9999.ebuild:
sci-mathematics/sage: update patch for 6.10.rc0 make repoman happy.

05 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.10-neutering.patch, sage-9999.ebuild:
sci-mathematics/sage: bump dependencies for 6.10.beta7

28 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: correct numpy dependency

28 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bump dependencies for 6.10.beta6

16 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: enforce dependency on sympy 0.7.6.1-r1 in sage-9999

12 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.10-neutering.patch, sage-9999.ebuild:
sci-mathematics/sage: update and rebase the neutering patch for upcoming sage
6.10

06 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: adjustements for 6.10.beta3 (arb is now standard and
there is a japanese translation)

04 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.10-jupyter-r2.patch:
sci-mathematics/sage: fix overzealous replacement in new jupyter patch

04 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.10-jupyter-r2.patch, +files/sage-6.10-sagedoc-r2.patch,
-files/sage-6.10-jupyter.patch, -files/sage-6.10-sagedoc.patch,
sage-9999.ebuild:
sci-mathematics/sage: New version of the jupyter patch. The kernel
installation bits are moved to sage_setup which in s-o-g is not installed and
therefore not doctested.

01 Nov 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: Update optional dependency on bliss in sage-9999

30 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: arb is now a standard package

27 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: more work on links

27 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: setting more symlinks as upstream intended.

27 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.10-jupyter.patch, -files/sage-6.10-ipython_kernel_start.patch,
-files/sage-6.10-jupyter_install.patch, sage-9999.ebuild:
sci-mathematics/sage: issue #376. Rewrite/maim/disable all the crap in
sage/repl/ipython_kernel/install.py and move logic in ebuild where
applicable. It may not be possible to find a convenient solution for upstream.

21 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: Add ja (japanese) to possible languages for future sage
6.10

21 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.10-ipython_kernel_start.patch,
+files/sage-6.10-jupyter_install.patch, +files/sage-6.10-sagedoc.patch,
+files/sage-6.10-sources.patch, sage-9999.ebuild:
sci-mathematics/sage: bump for sage 6.10.beta1

16 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: Add die calls for autogenrated code.

16 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: start work on 6.10.beta0

13 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-6.3-env.patch, -files/sage-6.6-blas.patch, -sage-6.6-r1.ebuild:
sci-mathematics/sage: dropping old sage 6.6

*sage-6.9 (13 Oct 2015)

13 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.9.ebuild, metadata.xml:
sci-mathematics/sage: 6.9 at last! Now with bin-pdf provided.

08 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.8-r2.ebuild, sage-9999.ebuild:
sci-mathematics/sage: pin pari version. Don't any surprises there.

07 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.8-r2.ebuild:
sci-mathematics/sage: extend the cython 0.23.3 fix to sage 6.8. It is more of
a case that cython 0.23.3 uncovered a bug than a specific problem to cython
0.23.3.

07 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/cython-0.23.3.patch, sage-9999.ebuild:
sci-mathematics/sage: bug fix in sage-9999 for using cython 0.23.3 may need to
backport to 6.8.

05 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.7-r2.ebuild, sage-6.8-r2.ebuild, sage-9999.ebuild:
sci-mathematics/sage: added subslot dependency on ecls so rebuild can be
triggered on ecls upgrade

22 Sep 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.7-r2.ebuild, sage-6.8-r2.ebuild:
sci-mathematics/sage: properly fix ipython dependency to ipython in 6.7 and
6.8 for issue #373

22 Sep 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.7-r2.ebuild, sage-6.8-r2.ebuild:
sci-mathematics/sage: add constraint on ipython version for 6.7 and 6.8 to fix
#373

17 Sep 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.9-neutering.patch, files/sage-6.9-exec.patch, sage-9999.ebuild:
sci-mathematics/sage: 6.9.beta7

16 Sep 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.3-env.patch, files/sage-6.7-env.patch, files/sage-6.8-env.patch:
sci-mathematics/sage: fix issue #372 - env.py has the wrong value for
SAGE_DOC.

10 Sep 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.9-exec.patch, sage-9999.ebuild:
sci-mathematics/sage: bump patches for 6.9.beta6.

04 Sep 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.9-exec.patch, sage-9999.ebuild:
sci-mathematics/sage: bump patch for 6.9.beta5, brial is replacing polybori in
this release. A block may need to be manually resolved.

28 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: small revision for 6.9.beta4, cython 0.23 support now
in, eclib dep bumped.

28 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.9-qt4_conflict.patch, sage-9999.ebuild:
sci-mathematics/sage:

*sage-6.6-r1 (26 Aug 2015)

26 Aug 2015; Martin von Gagern (MvG) <Martin.vGagern@gmx.net>
-sage-6.6.ebuild, +sage-6.6-r1.ebuild, -sage-6.7-r1.ebuild, -sage-6.8.ebuild,
-sage-6.8-r1.ebuild:
Drop revisions using old versions of flint

26 Aug 2015; Martin von Gagern (MvG) <Martin.vGagern@gmx.net>
sage-6.6.ebuild, sage-6.7-r1.ebuild, sage-6.8.ebuild, sage-6.8-r1.ebuild:
change double constraint to any-of constraint for flint version range

*sage-6.7-r2 (26 Aug 2015)

26 Aug 2015; Martin von Gagern (MvG) <Martin.vGagern@gmx.net>
sage-6.6.ebuild, sage-6.7-r1.ebuild, +sage-6.7-r2.ebuild:
revbump sage 6.7 as well for flint, while 6.6 depends on older flint

*sage-6.8-r2 (26 Aug 2015)

26 Aug 2015; Martin von Gagern (MvG) <Martin.vGagern@gmx.net>
sage-6.8-r1.ebuild, +sage-6.8-r2.ebuild, sage-9999.ebuild:
revbump to force recompilation against recent flint

21 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: bumping the neutering patch for 6.9.beta3

21 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.9-exec.patch:
sci-mathematics/sage: bump patch for 6.9.beta3

18 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.8-r1.ebuild, sage-6.8.ebuild:
sci-mathematics/sage: from 6.8 onwards post-install should warn about the lack
of html documentation if both html and bin-html are disabled. Fix issue #368

16 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sci-mathematics/sage: Introduce subslot for flint and ntl (one day we'll get
some)

13 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.9-exec.patch, sage-6.6.ebuild, sage-6.7-r1.ebuild,
sage-6.8-r1.ebuild, sage-6.8.ebuild, sage-9999.ebuild:
sci-mathematics/sage: bump patch for sage-9999, adapt ebuilds to new scheme.

10 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.8-r1.ebuild, sage-9999.ebuild:
pushing cython dependency to newly released 0.23 from the main tree.

09 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.8-r1.ebuild, sage-9999.ebuild:
bump sage-notebook dependency for issue #366

06 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
depend on the new graphs ebuild

06 Aug 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump dependencies for sage 9999

*sage-6.8-r1 (31 Jul 2015)

31 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.8-r1.ebuild:
sage 6.8-r1 uses cython 0.23_beta for issue #365

31 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/cython-0.23.patch, sage-9999.ebuild:
Testing migration to cython 0.23.beta in the live ebuild for issue #365. If
successful, it will be extended to sage 6.8.

29 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.9-exec.patch, sage-9999.ebuild:
bump patch for new sage 6.9.beta0

28 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.8-lazy_import_cache.patch, sage-6.8.ebuild, sage-9999.ebuild:
Fix for issue #362, use sage's version number for lazy_import_cache pickle
file rather than path to the source.

28 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.8.ebuild, sage-9999.ebuild:
dependency tweak in sage 6.8+

*sage-6.8 (27 Jul 2015)

27 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.8.ebuild, metadata.xml:
Bump to sage 6.8 - add to drop ~x86 because sci-mathematics/rw is not
keyworded (~)x86 and it makes repoman complains.

24 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
using glpk build without gmp will lead to (minor) doctest failures

22 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump dependency on elliptic curves ebuild

20 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.6.ebuild, sage-6.7-r1.ebuild, sage-9999.ebuild:
Move to newer pexpect. Pin notebook version depending on pexpect used.

16 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Another try at fixing what is now issue #361

16 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/ntl-9.3.0.patch, files/sage-6.8-exec.patch, sage-9999.ebuild:
patch rebasing, bumping and expanding for 6.8.rc0 - also remove ntl-9.3.0
patch now that it is useless and bumped pynac dependency.

13 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Correct the dependency on pynac in 9999. See issue #360

13 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-6.8-noclean.patch, files/sage-6.8-sources-r1.patch,
sage-9999.ebuild:
consolidate a couple of patches. Properly install the needed source files.

13 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/ntl-9.3.0.patch, files/sage-6.8-noclean.patch,
files/sage-6.8-sources-r1.patch, sage-9999.ebuild:
Bump to 6.8.beta8. It builds, it has to checked over for correctness so there
may be further tunning.

03 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bumping dependency on {lib}gap in 6.8.beta7, not doing ipython before checking
patches.

03 Jul 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.8-singular_extra_arg.patch, files/sage-6.8-blas-r1.patch,
sage-9999.ebuild:
patch bump for 6.8.beta7

28 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.7-r1.ebuild, sage-9999.ebuild:
Limit cython dependency to 0.22 releases in 6.7 and 9999, 0.22.1 is now going
stable and will create trouble.

26 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-6.0-safepython.patch, -files/sage-6.0-sagedoc.patch,
-files/sage-6.4-blas.patch:
Removal of sage 6.5 for lack of ipython 2.4 which bothers repoman, patch clean
up.

26 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-sage-6.5.ebuild, files/sage-6.8-blas-r1.patch, files/sage-6.8-noclean.patch,
files/sage-6.8-sources-r1.patch, sage-6.7-r1.ebuild, sage-9999.ebuild:
Bump patche for 6.8.beta5

22 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.8-all.py.patch, sage-9999.ebuild:
bump for 6.8.beta5, still have to work out problems with numpy 1.9

*sage-6.7-r1 (18 Jun 2015)

18 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/MPL-1.4.patch, +sage-6.7-r1.ebuild, -sage-6.7.ebuild, sage-9999.ebuild:
Allow sage 6.7 and higher to use matplotlib 1.4.x/numpy-1.9.x

14 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Reverse stuff from trac 18558 to be able to run doctests

13 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump arb optional dependency

13 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.8-misc.patch, +files/sage-6.8-noclean.patch,
files/sage-6.8-env.patch, files/sage-6.8-sources-r1.patch, sage-9999.ebuild:
bump patches for 6.8.beta4

10 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.5.ebuild, sage-6.6.ebuild, sage-6.7.ebuild, sage-9999.ebuild:
remove blockers for ebuilds that haven't been used for a while and are now
gone.

09 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/remove-testjavapath-to-python-6.1.patch,
-files/remove-testjavapath-to-python.patch, -files/sage-4.4.2-flint.patch,
-files/sage-4.7.2-site-packages.patch, -files/sage-5.10-env.patch,
-files/sage-5.12-fix-r-doctest.patch,
-files/sage-5.8-fix-cremona-doctest.patch,
-files/sage-5.8-fix-cython-doctest.patch, -files/sage-5.8-fix-r-doctest.patch,
-files/sage-5.9-all.py, -files/sage-5.9-env.patch,
-files/sage-5.9-fix-mip-doctest.patch, -files/sage-5.9-safepython.patch,
-files/sage-6.0-doc_common.patch, -files/sage-6.0-ecm-package.patch,
-files/sage-6.0-env.patch, -files/sage-6.1-env.patch,
-files/sage-6.1-farey_explicit_cast.patch, -files/sage-6.2-r1-env.patch,
-files/sage-6.3-blas.patch, -files/sage-6.3-givaro_singular_extra.patch,
-files/sage-6.4.1-maxima.patch, -files/sage-6.6.beta5-ipython.patch,
-files/sage-blas.patch, -files/sage-doc-6.2-seealso.patch,
-files/sage-matroids.patch, -files/sage-pexpect.patch,
-files/trac12985-unicode.patch, -files/trac_13693-part1.patch,
-files/trac_14636_1.patch, -files/trac_14636_2.patch,
-files/trac_14636_2b.patch, -files/trac_14656.patch, -sage-5.10-r3.ebuild,
-sage-5.11-r4.ebuild, -sage-5.12-r1.ebuild, -sage-5.9-r3.ebuild,
-sage-6.0-r3.ebuild, -sage-6.1.1-r3.ebuild, -sage-6.2-r1.ebuild,
-sage-6.3-r1.ebuild, -sage-6.4-r1.ebuild, metadata.xml:
clean up old sage versions up to sage 6.5

08 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Move conway_polynomial to RDEPEND now that it is possible. It may soon be
possible to run the test suite from the ebuild thanks to this change. sagenb
tests may have to be run from its own ebuild.

05 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Added missing dependency on planarity in 9999. Thanks to Steve for pointing
out that it was missing from the final version.

05 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.8-maxima.lisp.patch, sage-9999.ebuild:
Final fix to build sage 6.8.beta3

05 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Removing conflicting dependencies

05 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-6.8-blas.patch, -files/sage-6.8-sources.patch:
pruning obsolete patches

05 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/proto.sage-env-6.8, +files/sage-6.6-linguas.patch,
+files/sage-6.7-misc.patch, +files/sage-6.8-blas-r1.patch,
+files/sage-6.8-env.patch, +files/sage-6.8-exec.patch,
+files/sage-6.8-sources-r1.patch, metadata.xml, sage-9999.ebuild:
sage 6.8.beta3 - beware this is an un-doctested monolithic ebuild. sage-clib
is no more and I am folding everything in.

01 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Fix for prefix should now be complete.

01 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Correction in the prefix support.

31 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Deal with old sage source folder if present

31 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.8-sources.patch, sage-9999.ebuild:
Add new patch to solve problems with sage 6.8.beta1+ this patch extends work
upstream at trac #18494. It addresses a multitude of issue beside the
principal: finally get rid of sage_setup, all source installed alongside code
and extensions - /usr/share/sage/src/sage is now a link.

27 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.8-blas.patch, sage-9999.ebuild:
various fixes for 6.8.beta1

27 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.2-r1.ebuild, sage-6.3-r1.ebuild, sage-6.4-r1.ebuild, sage-6.5.ebuild,
sage-6.6.ebuild, sage-6.7.ebuild, sage-9999.ebuild:
dev-python/pkgconfig is now in the main tree, removing our own version

24 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump neutering patch for 6.8.beta0

*sage-6.7 (18 May 2015)

18 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.7.ebuild:
sage 6.7 is released

16 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
updating the neutering patch again. SAGE_LOCAL is now imported from sage.env
everywhere, all imports from sage.misc.misc have been chenged.

14 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump dependencies for 6.7.rc0

14 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.7-env.patch, sage-9999.ebuild:
bump a few patches and pari dep for 6.7.beta5

05 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump pari dependency for 6.7.beta4. gdmodule is gone upstream (not so long ago
but before this beta) so removing from dependencies.

02 May 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.6.ebuild:
pin pari in sage 6.6. The next pari upgrade in
http://trac.sagemath.org/ticket/18340 require significant patching.

30 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r3.ebuild, sage-5.11-r4.ebuild, sage-5.12-r1.ebuild,
sage-5.9-r3.ebuild, sage-6.0-r3.ebuild, sage-6.1.1-r3.ebuild,
sage-6.2-r1.ebuild, sage-6.3-r1.ebuild, sage-6.4-r1.ebuild, sage-6.5.ebuild,
sage-6.6.ebuild, sage-9999.ebuild:
Just pining maxima for issue #313

28 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
unexpected clash in the neutering patchset

28 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump neutering patchset to remove sage/misc/dist.py

28 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump cython dependency in 9999≈y

24 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Make the bliss otional dependency actually compile

23 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.7-blas.patch:
sage-6.7-blas.patch was incomplete and causing doctest failures.

22 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bliss take 3. I had stupidly used double quotes for boolean variables.

22 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bliss the optional package take 2

22 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml,
sage-9999.ebuild:
bump the neutering patch for new crop of "is_installed_package". Adding the
offending package in question to use flags since it is in the tree.

21 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r3.ebuild, sage-5.11-r4.ebuild, sage-5.12-r1.ebuild,
sage-5.9-r3.ebuild, sage-6.0-r3.ebuild, sage-6.1.1-r3.ebuild,
sage-6.2-r1.ebuild, sage-6.3-r1.ebuild, sage-6.4-r1.ebuild, sage-6.5.ebuild,
sage-6.6.ebuild, sage-9999.ebuild:
Bump pynac dependency in sage-9999. Add slot dependency for gmp as required by
repoman.

16 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Now all clear to build 6.7.beta1. Change code so there is no problem like
spotted in issue #346 again where I forgot to add sage-doc-bin as a
dependency.

16 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.6.ebuild, sage-9999.ebuild:
Correct dependency on sage-doc/sage-doc-bin spotted in issue #346

16 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.7-blas.patch, sage-9999.ebuild:
All fixes needed up to 6.7.beta1

16 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.6.ebuild:
pin ipython to 3.0.0 in sage 6.6 as changes in 3.1.0 are modifying some
expected behavior.

*sage-6.6 (15 Apr 2015)

15 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.6.ebuild:
sage 6.6 is out

04 Apr 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.6-ipython_kernel_start.patch, sage-9999.ebuild:
ipython kernel start up fix. Should solve issue #342

29 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
more removal of coinor-cbc

29 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml,
sage-9999.ebuild:
Unfortunately the coinor-cbc extension is not in a working shape

29 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml,
sage-9999.ebuild:
Add coinor-cbc optional binding

29 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.5.ebuild:
Pin pari version used in sage 6.5

28 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml,
sage-9999.ebuild:
Add useflag and dependency for the option modular_decomposition code.

19 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Forgot to bump pari dependency in 6.6.beta6

19 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump for 6.6.beta6

17 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4-r1.ebuild, sage-6.5.ebuild, sage-9999.ebuild:
Adjust eclib dependency again

17 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r3.ebuild, sage-5.11-r4.ebuild, sage-5.12-r1.ebuild,
sage-5.9-r3.ebuild, sage-6.0-r3.ebuild, sage-6.1.1-r3.ebuild,
sage-6.2-r1.ebuild, sage-6.3-r1.ebuild, sage-6.4-r1.ebuild, sage-6.5.ebuild,
sage-9999.ebuild:
adjusted to new eclib versioning scheme

14 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r3.ebuild, sage-5.11-r4.ebuild, sage-5.12-r1.ebuild,
sage-5.9-r3.ebuild, sage-6.0-r3.ebuild, sage-6.1.1-r3.ebuild,
sage-6.2-r1.ebuild, sage-6.3-r1.ebuild, sage-6.4-r1.ebuild, sage-6.5.ebuild,
sage-9999.ebuild:
Pin tachyon dependency in the sage ebuilds

14 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4-r1.ebuild, sage-6.5.ebuild:
Fixed ipython dependency in 6.4 and 6.5 to deal with issue #340

14 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.6.beta5-ipython.patch, sage-9999.ebuild:
just pushing the patch I sent upstream for ipython's behavior. Should be
included in the next beta.

13 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.6-sagedoc.patch, sage-9999.ebuild:
bump patch and dependency for 6.6.beta4

10 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
adjust dependency on sagenb in 9999

09 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.6-sagedoc.patch:
New iteration of the sagedoc patch for new location of documentation.

09 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.6-safepython.patch:
update safepython patch to include previously forgotten line

09 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.6-sagedoc.patch, files/sage-6.6-safepython.patch,
sage-9999.ebuild:
Improving the handling of the documentation

05 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Because of some changes to the building system we cannot remove all the
sources for clib. We have to keep the headers at least. The requirement is
likely to go away when we completely eliminate clib.

05 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump pari version for 6.6.beta3. This is the big test of the work I have done
on the pari dependency handling.

03 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.5.ebuild, sage-9999.ebuild:
Lift the restriction on installing gmpy and sage at the same time. The
problems that gave rise to it in mpmath seem to have been fixed. See issue
#339.

01 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4-r1.ebuild, sage-6.5.ebuild:
Adjust cython versions available for 6.4 and 6.5 see issue #336

01 Mar 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.6-blas.patch, sage-6.3-r1.ebuild, sage-6.4-r1.ebuild,
sage-6.5.ebuild, sage-9999.ebuild:
bump for 6.6.beta2. Bump ipython dependency of old sage ebuild to something in
the tree.

23 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.6-safepython.patch, sage-9999.ebuild:
Bump some patches. Finally figured that the big failing doctest in cmdline.py
was test the -fixdoctest switch which is of course removed here.

22 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4-r1.ebuild, sage-6.5.ebuild:
pin down cython in 6.4 and 6.5. We don't to try them with cython 0.22+

21 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml,
sage-9999.ebuild:
bump the neutering patch for the inclusion of the new optional dependency on
arb. Make arb a useflag.

21 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
upstream trivially upgraded ipython for 2.3.0 to 2.4.1 without change to
sage's code so any ipython from 2.3.0 to 2.4.1 is good.

21 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump gap dependency for sage 6.6.beta1

18 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump cython dependency for 6.6.beta0

*sage-6.5 (18 Feb 2015)

18 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.5.ebuild:
6.5 is out

14 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Adjust maxima dependency in sage 9999 for upcoming 6.5 release.

09 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bumping neutering patch again...

08 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump the neutering patch *again*

30 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump sagenb dependency see http://trac.sagemath.org/ticket/17645

30 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump package patch (again) for sage 6.5

29 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4-r1.ebuild, sage-9999.ebuild:
adjust pari dependencies in 6.4 and 9999

26 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump dependency on sage-data-graphs in sage-9999

26 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump neutering patch again. This time all t are crossed and all the i are
dotted.

26 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r3.ebuild, sage-5.11-r4.ebuild, sage-5.12-r1.ebuild,
sage-5.9-r3.ebuild, sage-6.0-r3.ebuild, sage-6.1.1-r3.ebuild,
sage-6.2-r1.ebuild, sage-6.3-r1.ebuild, sage-6.4-r1.ebuild, sage-9999.ebuild:
bump neutering patch again for stuff missing in the previous version. Clean up
of ebuilds.

26 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump neutering patches for 6.5.beta6. Also sqlalchemy is no more a standard
sage package.

21 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Fix location of jmol in jmoldata.py for new sage-jmol-bin

12 Jan 2015; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump sagenb dependency in 9999

04 Dec 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.3-r1.ebuild, sage-6.4-r1.ebuild, sage-9999.ebuild:
Fix numpy dependency to 1.8* for sage 6.2 to 9999

27 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Work around issues with sage_setup removal. Not sure how it got unnoticed
before.

27 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sage 9999 depends on (lib)singular 3.1.7_p1 again. Not doing so will lead to 2
doctests failure.

25 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Hopefully with the new maxima fix, maxima won't leak output like crazy in
doctest. Off course we could have reversed sage-6.4.1-maxima patch instead
for the same effect I think.

*sage-6.4-r1 (25 Nov 2014)

25 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.4.1-maxima.patch, +sage-6.4-r1.ebuild, -sage-6.4.ebuild:
bump 6.4 to 6.4-r1 for the only fix from 6.4.1 that we should practically
include. This is mainly so we are not in a mess with regards to maxima
dependencies.

25 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
(lib)singular 3.1.7 is not really needed, depending on 3.1.6 until I fixed
libsingular 3.1.7_p1 to install properly.

25 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
updating 9999 ebuild for sage 6.5.beta1

19 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4.ebuild:
sage 6.4 can use either sage-doc or sage-doc-bin

19 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Remove sage_setup (thought I had already done so)

18 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Remove a tab from the neutering patch

18 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump neutering patch for new is_package_install instances. Improved way of
dealing with optional runtime dependencies.

17 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4.ebuild, sage-9999.ebuild:
Adjust runtime dependency on ipython

16 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4.ebuild, sage-9999.ebuild:
Adjusting dependencies on R and ecls

16 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Bump gap in 9999 as well.

16 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.4.ebuild:
forgot to bump gap dependency. Doesn't seem to be that important.

*sage-6.4 (16 Nov 2014)

16 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.4.ebuild:
6.4 is out: sage

05 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
cygdb info is currently installed in the wrong folder. Fixing in 9999 but a
better solution would be nice.

*sage-5.12-r1 (05 Nov 2014)

05 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-5.12-r1.ebuild, -sage-5.12-r1.ebuild::
remove ":" in "sage-5.12.ebuild:" created by a previous commit

*sage-5.10-r3 (04 Nov 2014)
*sage-5.11-r4 (04 Nov 2014)
*sage-5.9-r3 (04 Nov 2014)
*sage-6.0-r3 (04 Nov 2014)
*sage-6.1.1-r3 (04 Nov 2014)
*sage-6.2-r1 (04 Nov 2014)
*sage-6.3-r1 (04 Nov 2014)

04 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-5.10-r3.ebuild, +sage-5.11-r4.ebuild, +sage-5.12-r1.ebuild:,
+sage-5.9-r3.ebuild, +sage-6.0-r3.ebuild, +sage-6.1.1-r3.ebuild,
+sage-6.2-r1.ebuild, +sage-6.3-r1.ebuild, -files/sage-5.11-ppl1.patch,
-files/sage-6.0-ppl1.patch, -files/sage-6.2-r1-ppl1.patch,
-files/sage-6.3-ppl1.patch, -files/sage-6.4-ppl1.patch, -sage-5.10-r2.ebuild,
-sage-5.11-r3.ebuild, -sage-5.12.ebuild, -sage-5.9-r2.ebuild,
-sage-6.0-r2.ebuild, -sage-6.1.1-r2.ebuild, -sage-6.2.ebuild,
-sage-6.3.ebuild, sage-9999.ebuild:
move back to dev-libs/ppl now that 1.1 is in the main tree. Note that the
current glpk dependency in the main tree is wrong.

31 Oct 2014; François Bissey <francois.bissey@canterbury.ac.nz>
-files/maxima-5.29.1-doctests.patch, -files/sage-5.0-degree-sequence.patch,
-files/sage-5.4-package.patch, -files/sage-5.4-plural.patch,
-files/sage-5.4-variables.patch.bz2, -files/sage-5.6-variables.patch,
-files/sage-5.7-libgap.patch, -files/sage-5.8-fix-cmdline-doctest.patch,
-files/sage-5.8-fix-numpy-doctests.patch, -files/trac12205.patch,
-files/trac13262_update_doctests.patch, -files/trac_13324.2.patch,
-files/trac_13324.patch, -files/trac_13740_final_fixes.patch,
-sage-5.6-r4.ebuild, -sage-5.7-r5.ebuild, -sage-5.8-r4.ebuild, metadata.xml,
sage-9999.ebuild:
update sage-9999 for 6.4.rc0. Drop sage 5.6, 5.7 and 5.8 because cython-0.18
is gone from the tree and it makes repoman unhappy. More clean up to follow.

17 Oct 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
add new dependencies to sage

17 Oct 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.4-blas.patch, sage-9999.ebuild:
6.4.beta6: sage

29 Sep 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
relax pari dependency a little bit

28 Sep 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.4-blas.patch, -files/sage-6.4-dgs_gauss.patch, sage-9999.ebuild:
Bump dependencies for 6.4.beta4 as well as blas patch. eclib not updated yet,
but it is only useful to use ntl 6.2+.

18 Sep 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.3.ebuild, sage-9999.ebuild:
Really restricting matplotlib to under 1.4 not including 1.4.0 itself.

15 Sep 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.3.ebuild, sage-9999.ebuild:
we don't want matplotlib 1.4.x just yet

12 Sep 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.4-dgs_gauss.patch, sage-9999.ebuild:
fixing dgs_misc.h issue.

11 Sep 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
update dependencies for 6.4.beta3

28 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r2.ebuild, sage-5.11-r3.ebuild, sage-5.12.ebuild,
sage-5.6-r4.ebuild, sage-5.7-r5.ebuild, sage-5.8-r4.ebuild,
sage-5.9-r2.ebuild, sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild, sage-6.2.ebuild,
sage-6.3.ebuild, sage-9999.ebuild:
adjust dependencies in 9999 for upcoming sage 6.4 - more to come.

27 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
accept newer eclib in 9999, probably safe for earlier sage too.

21 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
enforce dependency to maxima 5.33.0-r1 in sage-9999

21 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.4-ppl1.patch, sage-9999.ebuild:
update patch for 6.4.beta1

20 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.4-givaro_singular_extra.patch, sage-9999.ebuild:
Update singular/givaro patch for 6.4.beta0

*sage-6.3 (15 Aug 2014)

15 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.3.ebuild:
sae 6.3

14 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r2.ebuild, sage-5.11-r3.ebuild, sage-5.12.ebuild,
sage-5.6-r4.ebuild, sage-5.7-r5.ebuild, sage-5.8-r4.ebuild,
sage-5.9-r2.ebuild, sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild, sage-6.2.ebuild,
sage-9999.ebuild:
move glpk dependency to subslots. adjust for sageupstream repo clean up.

13 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r2.ebuild, sage-5.11-r3.ebuild, sage-5.12.ebuild,
sage-5.6-r4.ebuild, sage-5.7-r5.ebuild, sage-5.8-r4.ebuild,
sage-5.9-r2.ebuild, sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild, sage-6.2.ebuild,
sage-9999.ebuild:
Dependency change to handle the migration to sage-upstream

29 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Fixing the last bit of sage/all.py doctests

29 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.3-doc_common.patch, files/sage-6.3-noclean.patch:
Refresh sage-6.3 patches to completely remove sage_setup and the associated
tests

29 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Add new data ppackage (combinatorial_designs) to dependencies for 9999

28 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Remove global DNDEBUG flag that shouldn't have been there anymore in 9999.

23 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-6.3-blas.patch, files/sage-6.3-ppl1.patch, sage-9999.ebuild:
Fix the refreshed patches

23 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.3-blas.patch, +files/sage-6.3-givaro_singular_extra.patch,
+files/sage-6.3-ppl1.patch, sage-9999.ebuild:
Refreshing some patch and change the handling of -DNDEBUG to handle the new
layout of module_list.py

22 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Updating dependencies for 6.3.beta6

05 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r2.ebuild, sage-5.11-r3.ebuild, sage-5.12.ebuild,
sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild, sage-6.2.ebuild, sage-9999.ebuild:
Make sure we depend on flint[ntl]

02 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.6-r4.ebuild, sage-5.7-r5.ebuild, sage-5.8-r4.ebuild:
Make polybori 0.8.2 dependency a python-r1 one

01 Jul 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r2.ebuild, sage-5.11-r3.ebuild, sage-5.12.ebuild,
sage-5.9-r2.ebuild, sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild, sage-6.2.ebuild,
sage-9999.ebuild:
update polybori 0.8.3 dependency to python-r1 format. Deal with 0.8.2 later
(may be).

24 Jun 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.3-noclean.patch, sage-9999.ebuild:
Sage should try to clean its own install from within setup.py

24 Jun 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.3-doc_common.patch, +files/sage-6.3-env.patch, sage-9999.ebuild:
Update patch set for 6.3.beta4: new env.py, javatest.sh finally removed
upstream, doc_common changed.

23 Jun 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sage 6.3 will use ipython 2.1.0 - this version of ipython doesn't support
python 3.2 so the upgrade may cause breakage

06 Jun 2014; Christopher Schwan <cschwan@students.uni-mainz.de>
sage-6.2.ebuild, sage-9999.ebuild:
[sci-mathematics/sage] Updated einfo text

05 Jun 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bumpin neutering patch for 6.3.beta3

05 Jun 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
bump maxima dependency for sage 6.3.beta3

*sage-6.2 (28 May 2014)

28 May 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.2.ebuild, -sage-6.2-r1.ebuild:
Why did I want to bump 6.2 to r1?

*sage-6.2-r1 (28 May 2014)

28 May 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-doc-6.2-seealso.patch, +sage-6.2-r1.ebuild, -sage-6.2.ebuild,
sage-9999.ebuild:
compatibility with sphinx 1.2.x part1: sage bits

27 May 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Adjust dependency to numpy/scipy in 9999

26 May 2014; Christopher Schwan <cschwan@students.uni-mainz.de>
sage-6.2.ebuild, sage-9999.ebuild:
[sci-mathematics/sage] Move sage-doc from RDEPEND to PDEPEND - sci-
mathematics/sage-doc depends on sci-mathematics/sage and vice versa, but
sage needs to built first

*sage-6.2 (26 May 2014)

26 May 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.2.ebuild:
sage 6.2 - sorry for the delay :)

11 May 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r2.ebuild, sage-5.11-r3.ebuild, sage-5.12.ebuild,
sage-5.8-r4.ebuild, sage-5.9-r2.ebuild, sage-9999.ebuild:
Narrowing pari dependency since pari 2.7 is now in the main tree.

15 Apr 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.2-r1-env.patch, +files/sage-6.2-r1-ppl1.patch,
-files/sage-6.2-env.patch, -files/sage-6.2-ppl1.patch, sage-9999.ebuild:
Updated patch set for 6.2.beta8

09 Apr 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild:
properly fix issue #289 for sage 6.0 and 6.1.1

09 Apr 2014; François Bissey <francois.bissey@canterbury.ac.nz>
-sage-6.0-r1.ebuild, sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild,
sage-9999.ebuild:
Fix accessing octave from sage issue #289

02 Apr 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
6.2.beta6 bump: pynac 0.3.2 now in use

23 Mar 2014; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-doc-6.2-seealso.patch, sage-9999.ebuild:
6.2.beta5 work. the sage-doc seealso patch may need regenerating.

11 Mar 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
6.2.beta4 is out a few change in dependencies.

10 Mar 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sage 6.2.beta3 has switched to cython 0.20.1

10 Mar 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
sage 6.2.beta3 now wants ntl6+

06 Mar 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-doc-6.2-seealso.patch, sage-9999.ebuild:
Getting ready for 6.2.beta3 and fixes to build docs

16 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
-files/sage-6.2-env.py:
Remove duplicate file

16 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.2-env.patch, +files/sage-6.2-env.py, sage-9999.ebuild:
various small fixes to get 6.2.beta2 to build.

16 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.2-pexpect.patch, sage-9999.ebuild:
Update sage-pexpect patch for 6.2.beta2

16 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
trac 15443 merged in 6.2.beta2 removing related patch

16 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-blas.patch:
updating blas patch for 6.2.beta2

16 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.0-r1.ebuild, sage-6.0-r2.ebuild, sage-6.1.1-r2.ebuild,
sage-9999.ebuild:
fix pari dependencies for upcoming sage 6.2

13 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-blas.patch:
Trying to be smart with cython.py

13 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-blas.patch:
It was building but not running. OO semantics it would be educational to have
the emails between me and steve in an issue :)

13 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-blas.patch:
much better cblas handling in -9999 thanks Steve for testing. Still stuff to
patch in cython.py but it should build and run with any cblas now.

11 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
little dependency adjustment to match upstream

11 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-blas.patch, sage-9999.ebuild:
Towards sage 6.2, lots of stuff. The new sage-blas patch probably needs
adjustment in cython.py but I don't remember what right now. But this has to
hit the road.

*sage-6.1.1-r2 (10 Feb 2014)

10 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.1.1-r2.ebuild, -sage-6.1.1-r1.ebuild, sage-5.10-r2.ebuild,
sage-5.11-r3.ebuild, sage-5.12.ebuild, sage-5.6-r4.ebuild, sage-5.7-r5.ebuild,
sage-5.8-r4.ebuild, sage-5.9-r2.ebuild, sage-6.0-r1.ebuild,
sage-6.0-r2.ebuild, sage-9999.ebuild:
Pinning down libcliquer dependency for sage older than sage 6.2

07 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
develop is now based on 6.1.1 so bumping notebook dependency. More dependency
work needs to go in so don't be shock if it is broken.

*sage-6.1.1-r1 (07 Feb 2014)

07 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+sage-6.1.1-r1.ebuild, -sage-6.1.1.ebuild:
bumping sage-notebook dependency in sage-6.1.1 to close issue #278

*sage-6.1.1 (07 Feb 2014)

07 Feb 2014; Christopher Schwan <cschwan@students.uni-mainz.de>
+sage-6.1.1.ebuild:
Version bump

05 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-6.0-r2.ebuild, sage-9999.ebuild:
Finally correct syntax for issue #231

*sage-6.0-r2 (05 Feb 2014)

05 Feb 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-pexpect.patch, +sage-6.0-r2.ebuild, sage-9999.ebuild:
Start migration to sage-pexpect issue #231

29 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.12.ebuild, sage-6.0-r1.ebuild, sage-9999.ebuild:
Pin down cython version in latest sage to avoid 0.20

24 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
files/sage-5.10-env.patch, files/sage-5.9-env.patch, files/sage-6.0-env.patch,
files/sage-6.1-env.patch:
fix env patches for issue #272

20 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.1-farey_explicit_cast.patch, sage-9999.ebuild:
Solve issue #271 thanks to Steve Trogdon for the patch

07 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
Incorporate sagedoc doctest fix to 9999

07 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-9999.ebuild:
update the neutering patch for sage 6.1.beta4

06 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+files/remove-testjavapath-to-python-6.1.patch, +files/sage-6.1-env.patch,
sage-9999.ebuild:
9999 is now building at the 6.1.beta4 level

02 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.10-r2.ebuild, sage-5.11-r3.ebuild, sage-5.12.ebuild,
sage-5.6-r4.ebuild, sage-5.7-r5.ebuild, sage-5.8-r4.ebuild,
sage-5.9-r2.ebuild, sage-6.0-r1.ebuild, sage-9999.ebuild:
Cleaning up dependencies of sage for ntl (<6.0.0) and (lib)singular (~3.1.5)
for all current ebuild.

01 Jan 2014; François Bissey <francois.bissey@canterbury.ac.nz>
sage-5.12.ebuild, sage-6.0-r1.ebuild:
bumping libsingular dependency in 5.12 and 6.0. Simultaneous upgrade to latest
singular 3.1.5 recommended. 6.1 is supposed to use singular 3.1.6

*sage-6.0-r1 (30 Dec 2013)

30 Dec 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+files/sage-6.0-sagedoc.patch, +sage-6.0-r1.ebuild, -sage-6.0.ebuild:
Fix doct