gpo.zugaina.org

Search Portage & Overlays:

sci-libs/libgap

A cython library interface to gap for sage

Screenshots

  • libgap-4.8.3
    ~x86 ~amd64 ~ppc-macos ~x86-macos ~x64-macos
    static-libs

    View      Download      Browse     License: GPL-2   
    Overlay: sage-on-gentoo (layman)

ChangeLog

06 Aug 2016; François Bissey <francois.bissey@canterbury.ac.nz>
-libgap-4.7.8.ebuild:
sci-libs/libgap: remove old

05 Apr 2016; François Bissey <francois.bissey@canterbury.ac.nz>
-libgap-4.8.1.ebuild:
sci-libs/libgap: remove unused

*libgap-4.8.3 (29 Mar 2016)

29 Mar 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.8.3.ebuild:
sci-libs/libgap: bump to latest

31 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz> metadata.xml:
sci-libs/libgap: update metadata

*libgap-4.8.1 (21 Jan 2016)

21 Jan 2016; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.8.1.ebuild:
sci-libs/libgap: 4.8.1 for sage 7.1

20 Dec 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-libgap-4.7.7.ebuild:
sci-libs/libgap: remove unused

13 Oct 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-libgap-4.7.5-r1.ebuild:
sci-libs/libgap: remove old

06 Sep 2015; François Bissey <francois.bissey@canterbury.ac.nz>
libgap-4.7.5-r1.ebuild, libgap-4.7.7.ebuild, libgap-4.7.8.ebuild:
sci-libs/libgap: Make sure AUTOTOOLS_AUTORECONF is in the right spot as per
documentation

*libgap-4.7.8 (19 Jun 2015)

19 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.7.8.ebuild:
bump libgap to match new gap for sage 6.8

09 Jun 2015; François Bissey <francois.bissey@canterbury.ac.nz>
-files/libgap-4.5.7-libm.patch, -files/libgap-4.5.7-printf.patch,
-libgap-4.5.7-r1.ebuild, -libgap-4.5.7_p2-r1.ebuild, -libgap-4.6.4.ebuild,
-libgap-4.7.4.ebuild:
remove old unused and unusable libgap

*libgap-4.7.7 (21 Feb 2015)

21 Feb 2015; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.7.7.ebuild:
bump libgap for 6.6.beta1 - should be compatible with 4.7.5

*libgap-4.7.5-r1 (18 Nov 2014)

18 Nov 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.7.5-r1.ebuild, -libgap-4.7.5.ebuild:
Bump libgap 4.7.5 to use 4.7.5.1 minor update from Volker

*libgap-4.6.4 (14 Aug 2014)

14 Aug 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.6.4.ebuild, -libgap-4.6.4_p0.ebuild, libgap-4.5.7-r1.ebuild,
libgap-4.7.4.ebuild, libgap-4.7.5.ebuild:
move most libgap to EAPI 5 and sage upstream repo

*libgap-4.7.5 (19 Jun 2014)

19 Jun 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.7.5.ebuild, libgap-4.7.4.ebuild:
bump to 4.7.5 for upcoming sage 6.3. minor adjustment to SRC_URI in 4.7.4 to
keep repoman happy.

*libgap-4.7.4 (06 Mar 2014)

06 Mar 2014; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.7.4.ebuild, -libgap-4.7.2.ebuild:
Bump libgap to match gap

*libgap-4.7.2 (27 Dec 2013)

27 Dec 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.7.2.ebuild:
Get a libgap matching gap

15 Dec 2013; François Bissey <francois.bissey@canterbury.ac.nz>
libgap-4.6.4_p0.ebuild:
Revert gap/gap-lite stuff

15 Dec 2013; François Bissey <francois.bissey@canterbury.ac.nz>
libgap-4.6.4_p0.ebuild:
libgap can use either gap or gap-lite

*libgap-4.6.4_p0 (03 Jul 2013)

03 Jul 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.6.4_p0.ebuild:
libgap 4.6.4 for sage 5.11

20 Apr 2013; François Bissey <francois.bissey@canterbury.ac.nz>
libgap-4.5.7-r1.ebuild, libgap-4.5.7_p2-r1.ebuild:
Restricting tests in libgap

17 Apr 2013; François Bissey <francois.bissey@canterbury.ac.nz>
libgap-4.5.7-r1.ebuild, libgap-4.5.7_p2-r1.ebuild:
Build libgap in source. If out of sources the config.h already present in
sources will be used. If we remove this config.h and build out of sources it
fails. So it is not ready to build out of sources.

*libgap-4.5.7-r1 (16 Apr 2013)
*libgap-4.5.7_p2-r1 (16 Apr 2013)

16 Apr 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+files/libgap-4.5.7-libm.patch, +libgap-4.5.7-r1.ebuild,
+libgap-4.5.7_p2-r1.ebuild, -libgap-4.5.7.ebuild, -libgap-4.5.7_p2.ebuild:
Resolve libm symbols in libgap

26 Mar 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+files/libgap-4.5.7-printf.patch, libgap-4.5.7.ebuild, libgap-4.5.7_p2.ebuild:
include upstream patch to libgap 4.5.7 I am hopeful it will be in 4.6.2

*libgap-4.5.7_p2 (25 Mar 2013)

25 Mar 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.5.7_p2.ebuild:
Bump to latest 4.5.7, forwarded QA upstream.

*libgap-4.5.7 (04 Feb 2013)

04 Feb 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+libgap-4.5.7.ebuild, +metadata.xml:
New ebuild for libgap to be used in sage 5.7